Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an OpenSUSE server, I have disable login by password and only allow authorized_keys to log in. However, when I restart my server, I got the weird terminal

(none):~ #

But things are still ok so far. So I dont know if it is a big problem or not ?

share|improve this question
1  
Due to '#' in prompt, your user is root. Seems like something happened with your .$(SHELL)rc. Default shell is bash, so if you didn't change it, check if /root/.bashrc is readable and is ok. You can check your current shell with echo $SHELL command. –  rush Dec 12 '11 at 18:17
2  
...and what is your prompt supposed to be? (echo $PS1) –  voretaq7 Dec 12 '11 at 18:32
    
are you in single user mode? Sounds like you might be. what does "/sbin/runlevel" return? does "cat /proc/cmdline" end with "single"? what does "whoami" return? –  stew Dec 12 '11 at 19:43
    
-rw-r--r-- 1 root root 73 Dec 7 23:56 .bashrc echo $SHELL /bin/bash My prompt supposed to be: li62-392:~ # runlevel N 3 cat /proc/cmdline root=/dev/xvda xencons=tty console=tty1 console=hvc0 nosep nodevfs ramdisk_size=32768 ip_conntrack.hashsize=8192 nf_conntrack.hashsize=8192 ro devtmpfs.mount=1 whoami root Thank all for your comments –  laoshanlung Dec 13 '11 at 3:20
    
Sorry I cant make the comment to be formatted. –  laoshanlung Dec 13 '11 at 3:25
add comment

1 Answer

Check the settings of "use pam" and "use login" in your sshd-configuration. It seems that during ssh-login your environment is not set up correctly.

Either that - or you did not set your hostname properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.