Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In IIS 7, you can view the worker processes and see which requests are currently executing. I am encountering some requests that remain in the "ExecuteRequestHandler" stage for hours - basically until the application pool is recycled. I am unsure why this is happening but it appears to correlate with "connection_dropped" errors in the httperr.log file.

I want to ensure these requests aren't tying up resources (we're seeing memory spikes as well, though I can't necessarily tie the two together; CPU for the requests is 0%), so is there a way to limit the amount of time a request can have? I found one for classic ASP but nothing for .NET.

share|improve this question

You should be able to modify the executionTimeout attribute of the httpRuntime in either your application web.config or in machine.config to an appropriate value. Documentation here.

share|improve this answer
Thanks, I'll give it a try. It says the default is 110, so I wonder if something is interfering. Debug should already be off. – Bitwise Dec 13 '11 at 2:53
This does seem to be the proper way of setting things, but it unfortunately did not resolve my issue. – Bitwise Dec 14 '11 at 23:07
How did it not resolve the issue? – friism Dec 19 '11 at 7:41
The requests continue to persist in IIS for many hours. – Bitwise Dec 23 '11 at 2:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.