Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I haven't worked a lot with linux. I recently got a VPS at 1and1.com where I installed a LAMP server and then Litecommerce. I had to format it a few times because I keep losing access to SSH within a day.

At the moment, website still runs fine, and when I still could monitor RAM I wasn't busting the limit. I also made sure that the firewall wasn't blocking the ports.

Gradually FTP, HTTPS and PING has also stopped working.

I guess I'm doing something wrong with my LAMP setup. Do you guys have any Idea of what could be the cause, where should I look for errors? Also, is there a way I can gain access to my machine again without having to re-image it?

edit: I haven't solved the problem. I re-imaged the server with a CentOS minimal install. I don't know if the problem was coming from the control pannels (plesk) installed on the previous image I used. Same code runs fine now.

share|improve this question
    
What do you mean by losing access to SSH? What do you mean by "stopped working?" –  cwallenpoole Dec 13 '11 at 15:41
    
The 1and1 control pannel says "service unavailable". My SSH client says "unable to connect to server" I will retry the TCP handshake in a few hours, to give you the exact error message, by memory, I think it timed out on port 22, it was refused on random ports and worked on port 80. –  Phillaf Dec 13 '11 at 15:54

2 Answers 2

It seems highly odd that the 1&1 Management interface would not be able to communicate with the VPS either.

Have you queried this with the host?

Installing LAMP would not cause SSH to fail and especially not ping.

Does the VPS respond to anything? Are you sure your connection is stable? Have you configured any firewall restrictions?

Does the 1&1 system feature a console access that you can use to access the device rather than using network based communications such as SSH?

share|improve this answer
    
1&1 provides 2 spearate control pannels. The first is their own, where I can chose to re-image the machine or check the status of specific ports. The other is called virtuozzo, run as a webapp on my own virtual machine, and let me monitor services, performance etc. I think I can access the machine to some extend. Virtuoso is not accessible right now since https doesn't work.The VPS still works, i can get in phpmyadmin and change data in the DB. An for the firewall, I tried letting all through without success –  Phillaf Dec 13 '11 at 19:44

Are the daemons running (running with the daemons, anyone?)? If you do a port scan on your server, does it show port 22 open? What are you doing on the server when everything quits working (how you describe it, it sounds like they're shutting off one by one, all by itself)? Is SELinux enabled? Have you checked it's audit logs to see if it's interrupting? Have you checked your security logs? Anything out of the ordinary? Do you have some sort of control panel that gives you console access to the server (i.e. can you access it without using SSH)? If so, can you get it and run netstat and see if anything is even listening on port 22?

Obviously you don't need to answer all of those questions. I'm just trying to provide different ideas to troubleshoot this. Post anything of interest that you find.

Also, it might be a good idea to call 1and1.com support to see if they have a hand in any of this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.