Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to do a full backup of a Windows Server 2008 R2 machine using backup PC (via SMB). My server is running Scientific Linux 6.1, with Backup PC 3.2.1.

I have changed the local security policy on the server 2008 machine to allow me to connect via smb, however, every time I do a full backup, I get about 80 errors. All the errors are similar to:

NT_STATUS_ACCESS_DENIED listing \Documents and Settings\*

These are all junction points that Windows 7 and 2008 use for backwards compatibility (you can't actually double click to open them).

I have tried excluding a bunch of ways in case my syntax was wrong (via the web gui).. and nothing seems to actually exclude it from scanning those files. For example:

\Documents and Settings\*
\Documents and Settings\
\Documents and Settings
\Documents\ and\ Settings\*
\Documents\ and\ Settings\
\Documents\ and\ Settings

I'm running out of ideas. My other exclusions seem to work.. but I don't want it even looking at these, let alone the

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Try doubling the initial backslash. Also, don't bother trying to escape the spaces with backslashes: that doesn't work. For example, the following setting (entered through the BackupPC web GUI) works for me:

\\Documents and Settings

Although the "Official" BackupPC documentation is generally very good, it really does fall short in this case. Fortunately, there are "unofficial" docs available through the BackupPC wiki that fill in some of the gaps. In particular, the Tips and Tricks page contains a lot of good information for admins and end-users.

share|improve this answer
    
Thank you, that was helpful! however, I'm still having trouble with some other folders that are not at the root, for example: NT_STATUS_ACCESS_DENIED listing \ProgramData\Application Data* I can't figure out the syntax to exclude this.. any ideas? –  Brian Dec 13 '11 at 20:38
    
@Brian: So \\ProgramData\Application Data doesn't work? I must admit, I haven't ever needed to exclude subdirectories, so if that doesn't work, I don't have anything else to suggest, sorry. –  Steven Monday Dec 13 '11 at 22:28
add comment

You should be using the Linux/Unix directory syntax for exclusions - i.e. use slashes instead of backslashes like this:

/ProgramData/Application Data
share|improve this answer
    
Perhaps it could depend on the version of smbclient that BackupPC is using? I don't know. All I know for certain is that I've never had any luck using forward slashes for exclusions on SMB shares. For me, the only successful exclusions have used backslashes. –  Steven Monday Dec 14 '11 at 2:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.