Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got Jenkins running under Tomcat 6. It's running as user tomcat6, with a home directory of /usr/share/tomcat6. I would like to install rvm for this user so I can use it for testing, but I can't figure out ho - is it possible to install rvm for a service user? I tried running the rvm installation script as a build step for a project, here's what I got:

/tmp/tomcat6-tmp/hudson2846335381818356442.sh: 3: Syntax error: redirection unexpected Finished: FAILURE

I also tried a multi-user installation of rvm, but I couldn't get the tomcat6 user to use any rvm commands - it seemed like it didn't recognize that rvm was installed. I'd be grateful for any suggestions. Thanks.

share|improve this question

1 Answer 1

This looks like bash/zsh script running in SH shell, most likely this is caused by using dash instead of bash (and linking it to /bin/sh) - it's mostly Ubuntu problem.

Make sure your scripts are ran with bash or sh which is linked to bash, it will make the script working properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.