Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have ubuntu 10.04 server configured to ip address x.x.x.200 and also have windows server 2003 with ip address x.x.x.100 (already setup as www.some-domain.com)

Currently i trying to shutdown windows server 2003 and use only ubuntu 10.04 server, the main idea is to change ubuntu ip address to x.x.x.100 since the www.some-domain.com already configured to x.x.x.100 by ISP.

Tried changing several config. Likely all run fine, i can ping the new address, i can SSH, WinSCP, Ftp except Apache2 webserver now fail to start (no error message).

Any suggestion what ubuntu & apache config should i change?

content of /etc/hosts

127.0.0.1  localhost
x.x.x.100  some-domain.com some-domain

content /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
  address x.x.x.100
  netmask 255.255.255.0
  network x.x.x.10
  broadcast x.x.x.255
  gateway x.x.x.1

content of /etc/resolv.conf

search some-domain.com
nameserver x.x.3.5
nameserver x.x.3.6

content of /etc/apache2/httpd.conf

ServerName some-domain.com
share|improve this question
1  
Check if Apache is binded to previous IP addres httpd.apache.org/docs/2.1/bind.html –  Boban P. Dec 14 '11 at 14:27
1  
netmask 255.255.255.0 network x.x.x.10 If the network is correct, the netmask cannot be, and vice versa. Figure out which one is being used. –  adaptr Dec 14 '11 at 14:43
    
just remove network and broadcast. They can be correctly calculated without having to specify them. The only real reason to specify them is when you really know what you are doing and you are doing something very non-standard. –  stew Dec 14 '11 at 16:03
    
above only example address, as i said ping, ssh, ftp all run fine except apache –  Dels Dec 15 '11 at 1:36
add comment

2 Answers 2

If it fails to start, it is more than likely not your IP address that is wrong but some other configuration file.

Look in your apache2 logs and syslog.

share|improve this answer
add comment

Apache should log something to error log or syslog. Or for the final solution try to strace it, to see what is wrong:

 strace -f /etc/init.d/apache2 start
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.