Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a mongo 1.8.3 master/slave setup. slave replication works and tests (collection sizes, query results, updates) all pass.

when i am trying to dump a collection from the slave that actually has more than a few million documents, mongodump only exports 101 objects max (that fact is applicable to all the collections on the slave).

i've read this article in the MongoDB documentation but it's not helping out, still getting only 101 objects back.

share|improve this question
    
What is the full command that you're using (omitting authentication, of course)? –  Andrew M. Dec 14 '11 at 20:39
add comment

2 Answers

I suspect you may have a "nocursors" option in your mongoDB config file (or specified on the command line) - you should remove that option and your mongodump will succeed as expected. That option limits the returned results to a single batch and would explain the issue you are seeing. See the parameters listed here for more info:

http://www.mongodb.org/display/DOCS/Command+Line+Parameters

share|improve this answer
add comment

I tested and reproduced same problem in mongodb 2.2.3. /2.0.8
If you have wrong configured firewall for mongodump then mongodump only exports 101 documents. Try shutdown firewall or reconfigure it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.