Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running my pfSense gateway in a ESXi server. right now the server gets its time from the NTP server specified in the general settings section of the WebGUI.

I want to disable this so pfSense will only get its time from the local system which is controlled by VMware which is being sync to a local NTP server.

If I look at the FreeBSD manual it talks about changing the value of ntpdate_enable = YES to ntpdate_enable = NO in /etc/rc.conf.

Does this apply to pfSense also?

Oh yeah, here is what I was looking at. FreeBSD Handbook

share|improve this question

2 Answers 2

Just remove the NTP server under System>General Setup. You can't use any of the rc stuff from stock FreeBSD.

share|improve this answer
    
I am not able to leave the NTP field blank. pfSense returns the error, A NTP Time Server name may only contain the characters a-z, 0-9, '-' and '.'. I am guessing that is a bug. –  Solignis Dec 16 '11 at 4:01
    
@Solignis, are you running 1.2.x, or 2.0? Chris, I am able to recreate Solignis' "may only contain" error on 1.2.3. –  Royce Williams Dec 20 '11 at 7:56
    
@Royce Williams, I am running 2.0 –  Solignis Dec 20 '11 at 8:06
    
Did you get an anwer to this? I am running pfsense 2.1 and cant seem to permanently disable ntp –  mcfedr Oct 28 '13 at 12:09

An old thread I know, but for the benefit of anyone else landing here I found (in pfSense 2.2 anyway) that you still have to enter a timeserver but if you tick the "noselect" box against every timeserver you will completely disable NTP.

Unfortunately that also prevents pfSense acting as an NTP server so you can't use it as the time server on you local networks, which is inconvenient as it's likely to be the only server with access to all VLANs.

Our pfSense firewalls are virtualized and get accurate time from the hypervisor (a similar scenario to the OP, although we use Proxmox rather than ESXi). For the moment I have reverted to NTP synchronization with the hypervisor.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.