Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've tried a lot of possible solutions but no one helped:

pear install Text_Highlighter
Failed to download pear/Text_Highlighter within preferred state "stable", latest release is version 0.7.2, stability "beta", use "channel://pear.php.net/Text_Highlighter-0.7.2" to install


pear -d preferred_state=beta install -f channel://pear.php.net/Text_Highlighter-0.7.2
downloading Text_Highlighter-0.7.2.tgz ...
Starting to download Text_Highlighter-0.7.2.tgz (139,104 bytes)
..............................done: 139,104 bytes
ERROR: No releases in package.xml matched the existing operating system, extensions installed, or architecture, cannot install

Etc. Whereas 0.7.1 installs perfectly using the latest command

Any ideas?

UPD:

This is what php pyrus.phar install pear/Text_Highlighter-0.7.2 gives to me:

Downloading pear.php.net/Text_Highlighter

Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/PEAR=======================================================================>] 99% (134/135 kb)
Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/Archive_Tar================================================================>] 99% (288/289 kb)
Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/Structures_Graph=====================================================>      ] 93% (16/17 kb)
Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/XML_Util================================================================>   ] 96% (28/29 kb)
Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/XML_Parser===========================================================>      ] 93% (16/17 kb)
Connected...
Mime-type: application/octet-stream

Downloading pear.php.net/Console_Getopt======================================================>       ] 92% (14/15 kb)
Connected...
Mime-type: application/octet-stream

PHP Warning:  rmdir(/usr/.old-bin/X11): Not a directory in phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/Filesystem.php on line 66
PHP Stack trace:
PHP   1. {main}() /root/pyrus.phar:0
PHP   2. PEAR2\Pyrus\ScriptFrontend\Commands->run() /root/pyrus.phar:52
PHP   3. PEAR2\Pyrus\ScriptFrontend\Commands->install() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/ScriptFrontend/Commands.php:284
PHP   4. PEAR2\Pyrus\Installer::commit() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/ScriptFrontend/Commands.php:491
PHP   5. PEAR2\Pyrus\AtomicFileTransaction::removeBackups() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/Installer.php:349
PHP   6. PEAR2\Pyrus\AtomicFileTransaction\Manager->finish() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/AtomicFileTransaction.php:96
PHP   7. PEAR2\Pyrus\AtomicFileTransaction\Transaction\TwoStage->finish() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/AtomicFileTransaction/Manager.php:196
PHP   8. PEAR2\Pyrus\Filesystem::rmrf() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/AtomicFileTransaction/Transaction/TwoStage.php:107
PHP   9. rmdir() phar:///root/pyrus.phar/PEAR2_Pyrus-2.0.0a3/php/PEAR2/Pyrus/Filesystem.php:66
PEAR2\Pyrus\AtomicFileTransaction\MultiException: Warning: no all backup directories have been removed
 PEAR2\Pyrus\IOException: Unable to fully remove /usr/.old-bin
share|improve this question
    
did you try this metod> php pyrus.phar install pear/Text_Highlighter-0.7.2 –  B14D3 Dec 15 '11 at 22:04
    
@B14D3: just did it, with even worse results :-S –  zerkms Dec 15 '11 at 22:13
    
what is this operating system ?? linux or windows?? –  B14D3 Dec 15 '11 at 22:28
    
do you have all dependencies installed for Text_Highlighter-0.7.2 –  B14D3 Dec 15 '11 at 22:31
    
@B14D3: I don't know about dependencies (and even more - there is no dependencies described in package.xml). --alldeps changes nothing. Isn't dependencies tracking is what package managers were invited for? If I tracked dependencies by myself I wouldn't need pear at all. It is Ubuntu 10.04.3 LTS –  zerkms Dec 15 '11 at 22:44

2 Answers 2

up vote 0 down vote accepted

It was a bug in a package itself. Filled and fixed at http://pear.php.net/bugs/bug.php?id=19139

share|improve this answer

Right now the Text_Highlighter package has a dependency on PEAR, which means it will pull in a bunch of other packages. To install the package into a self-contained repository you can use:

mkdir Text_Highlighter
cd Text_Highlighter
php pyrus.phar `pwd` set bin_dir `pwd`/bin
php pyrus.phar `pwd` install pear/Text_Highlighter-0.7.2

Which will install Text_Highlighter-0.7.2 and all dependencies in the Text_Highlighter directory.

share|improve this answer
    
Thanks for your answer. Anyway it was a bug in the package description: pear.php.net/bugs/bug.php?id=19139 –  zerkms Jan 3 '12 at 21:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.