Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am developing a device which acts as a multicast host, and want to observe it as it responds to IGMP Queries.

My Catalyst 3560G is set up as follows (full config below): Port 0/1 is a TFTP server allowing the device under test to boot. Port 0/3 is the device under test. Port 0/14 is my PC running wireshark, and ostinato for sending the IGMP query. Ports 0/1 and 0/3 are on a VLAN together, and port 0/14 is monitoring port 0/3, with ingress sent to that same VLAN. Those are the only three ports on the switch connected to anything.

When I send the query, Wireshark captures the outgoing frame, and nothing else. My device under test receives the frame (I get debug output).

I would expect that the SPAN session would send me a copy of the IGMP query as it egresses on port 0/3, and a copy of the corresponding report when it ingresses port 0/3, but I see neither of these. The only indication I have that the device under test responds at all is the multicast received counter on Port 0/3, which increments at the right time (0-10 seconds after the query was sent).

What am I doing wrong?

Current configuration : 2490 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cs3560
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$WKu9$g6YTo5sW/vvVmpbVmgTye0
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
no ip dhcp use vrf connected
!
no ip igmp snooping
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
switchport access vlan 161
switchport mode access
!
! <snip>  uninvolved ports removed
!
interface GigabitEthernet0/3
switchport access vlan 161
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/14
!
no cdp run
!
control-plane
!
line con 0
line vty 0 4
password 123
login
line vty 5 15
password 123
login
!
monitor session 1 source interface Gi0/3
monitor session 1 destination interface Gi0/14 ingress untagged vlan 161
end
share|improve this question

1 Answer 1

Try using these commands:

monitor session 1 source interface Gi0/3 /both/

monitor session 1 destination interface Gi0/14 ingress untagged vlan 161
end
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.