Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I moved the hard drive from one machine (Win 7) to another (XP) and now certain folders tell me "Access denied". I am logged in as an administrator. I had a different account on the other machine. Neither account authenticated to anything besides the local machine. The old machine is apparently dead, so I can't do anything in there like change permissions, etc. How can I access these files?

Edit:

After changing the ownerships of all the files and folders on the drive, I am getting a different error. And it is troubling me deeply.

"xxx refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location."

No change after rebooting. Any ideas? Surely the files are still there, right?

share|improve this question
    
Also, "Check Disk" found no problems. –  Fantius Jul 1 '09 at 0:50
1  
Doesn't Win7/Vista redirect files if they were written to a non user area? (program files for example) Could it be you're finding those links, rather than the actual files? –  Tubs Jul 1 '09 at 11:46
    
Crap! I think you are right. I was having this problem on D:\Users\chris\My Documents. But the real data for that folder is in D:\Users\chris\Douments. Thank you! –  Fantius Jul 1 '09 at 11:50

2 Answers 2

up vote 1 down vote accepted

Can you try to edit the Access Control lists directly? Make sure "use simple file sharing" is disabled in the folder options, and then do: right click->security and edit the ownership of the files/directories.

In Windows, file ownership is not determined by usernames, but by security identifiers (SID), and these are different on every installation.

share|improve this answer
1  
SIDs, thought-- not GUIDs. Same purpose, different things. –  Evan Anderson Jun 30 '09 at 23:18
    
Eeer, yep, of course you are right.... –  Sven Jun 30 '09 at 23:27

Try taking ownership of the file/folder. In the security tab, click Advanced, select the Owner tab, and add the local administrator as the Owner of the directory. That should do the trick.

share|improve this answer
    
... and then ensure the local administrator permissions are appropriately set. They should be but it doesn't always work. –  John Gardeniers Jul 1 '09 at 0:33
    
I'm not sure what you mean by that. –  Fantius Jul 1 '09 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.