Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed the CAS role on an internal mail server in an attempt to move CAS to that server instead of an outward facing web server (which also happens to be the DC).

After installing CAS on the mail server, I removed CAS from the original server. However, all Outlook clients are STILL trying to connect to the previous server! For existing accounts, the Exchange server address is read-only and I cannot even change it to the new server name:

enter image description here

As you can see, I can't even change the address. I need to change it to the new server name, which on the client machine DNS is able to resolve FINE to the proper IP.

When I create a NEW account in outlook, I put in the new CAS server's address and upon clicking CHECK NAME, the server name field is automatically rewritten to the old CAS server!

I can put in the IP, NETBIOS, or DNS name of the internal CAS server and every time I CHECK NAME, the name gets automatically replaced with the old CAS server name (also the DC) and Outlook cannot connect.

Note: OWA works perfect to the new CAS server.

I'm at the end of my rope. The only ideas I have as to what this can be are: 1) Something in the AD name checking mechanism is forcing the client to use the old CAS address. No idea where I go to configure that.

2) A setting in Exchange needs to be set in order to make the new CAS server the default. But I already removed all references to the old CAS server in EMC and set the new CAS server address in all Client Access settings.

3) Could there be something in the 'Autodiscover' configuration that is screwing things up?

share|improve this question

1 Answer 1

I figured it out.

I went to Microsoft's Exchange Connectivity Tester and tested the autodiscover settings and it told me the "EXCH provider section is missing from the Autodiscover response".

That led me to a question on Serverfault here that contained the resolution in it.

Basically when you remove a CAS role, the mailbox database retained the RPCClientAccess setting and needed to be updated with the new CAS server name.

Thus all I had to do was issue the following PS command:

[PS] C:\>Get-MailboxDatabase -Server ex1.domain.local | Set-MailboxDatabase -RpcClientAccessServer ex2.domain.local
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.