Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to deploy TFS 2010 in a sandbox environment, and I created a managed service account for TFS. However, I seem to be unable to configure it in the Advanced Configuration Wizard.

Advanced Configuration Wizard dialog with validation errors

The error reported when I click 'test' is "TFS254021: The account name or password that you specified is not valid."

Any suggestions?

share|improve this question
    
i really wish someone had actually answered this, i just ended up creating the accounts with passwords on the domain based on this guide: msdn.microsoft.com/en-us/library/ms253149.aspx –  artfulhacker Apr 8 '13 at 21:31

3 Answers 3

Account names ending in a $ are normally machine accounts, not user (even non-iterative user) accounts.

It is quite possible that TFS, or something that TFS uses, assumes this and thus blocks the name.

(Otherwise, be very sure you have correctly typed the password. I've ended up using copy and paste for both account creation and its use to allow a long and complex password but avoiding typos.)

share|improve this answer
    
This seems like the best answer. –  Tim Elhajj Dec 17 '11 at 17:39
    
MSAs don't have passwords.... –  artfulhacker Apr 8 '13 at 21:32

Is this service account user in the Administrator group on the TFS server?

share|improve this answer
    
No. Does it need to be? –  Ben Collins Dec 16 '11 at 22:47
    
@BenCollins The TFS server account does not need to be a local administrator (running here without being a member). –  Richard Dec 17 '11 at 9:00
    
Never put TFS service account into local administrators group –  Tim Elhajj Dec 17 '11 at 17:38
    
@BenCollins My bad, Tim is right, you want to just grant it the ability to run a service on that system –  orbitron Dec 19 '11 at 19:24

Remove the $ from the name of the account and try again. Make sure the account has Log on as a service permissions. Don't put it in the local admin group. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.