Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My ASA 5510 has the following configuration for an interface. My Ubuntu box (2.6.35) connected to this network will correctly autoconf an IPv6 address, but it will not set a default route.

interface Ethernet0/0.10
 vlan 10
 no shutdown
 nameif inside
 security-level 100
 ip address 172.18.0.1 255.255.254.0
 ipv6 address REMOVED:1::1/64
 ipv6 nd prefix REMOVED:1::/64
 ipv6 nd ra-interval 120
 ipv6 enable

Thus, ping6 REMOVED:1::1 works fine and if I manually add a default route for IPv6 it works fine.

The resulting router advertisement looks like this:

01:06:42.253895 IP6 (class 0xe0, hlim 255, next-header ICMPv6 (58) payload length: 64) fe80::21c:58ff:fed3:ea36 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 64
        hop limit 64, Flags [none], pref medium, router lifetime 1800s, reachable time 0s, retrans time 1000s
          source link-address option (1), length 8 (1): 00:1c:58:d3:ea:36
            0x0000:  001c 58d3 ea36
          mtu option (5), length 8 (1):  1500
            0x0000:  0000 0000 05dc
          prefix info option (3), length 32 (4): REMOVED:1::/64, Flags [onlink, auto], valid time 2592000s, pref. time 604800s
            0x0000:  40c0 0027 8d00 0009 3a80 0000 0000 XXXX
            0x0010:  XXXX XXXX 0001 0000 0000 0000 0000

How come I do not get a default gateway set?

share|improve this question

2 Answers 2

You can debug the process on the ubuntu box (a bit) with:

rdisc6 -v eth0

See if the advertisment matches what you expect.

share|improve this answer
up vote 1 down vote accepted

For unclear reasons, this problem no longer persists. It may be that it disappeared on Ubuntu upgrade.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.