Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't connect via TCP/IP to the MySQL server.

The server is installed in a Debian Linux and there's a PostGreSQL server running at the same time. (which is working fine and has tcp/ip connection btw)

But everytime I try to remotely connect to the MYSQL server I get the following:

Connecting to MySQL server
Access denied for user 'root'@'' (using password: YES)

Am I missing something here? I can log in fine if I run a SSH connection to the server. I also DID change the mysql.conf file to remove the BLINDIP setting.

btw: I tried also using the line


I get a reply:

Query OK, 0 rows affected (0.00 sec)

And still no remote access. (I'm pretty sure the 0 rows affected has something to do with it)

share|improve this question

migrated from Dec 18 '11 at 10:05

This question came from our site for professional and enthusiast programmers.

The default installation often only add privileges for root@localhost and there's usually a parameter called bind-address set to localhost as well. Have you checked this? – Fluff Dec 16 '11 at 18:26
-1, the reason is very obvious (remote connect vs ssh) – ajreal Dec 16 '11 at 18:37
The bind-address has been fixed already. I still need to grant privileges? How? – Johnny Bigoode Dec 16 '11 at 18:45
Check the ACL, if remote connect is direct from your pc, you remote address is different. – ajreal Dec 16 '11 at 19:14
ACL? Could you be more specific? There's no mention of ACL on the MYSQL manual. – Johnny Bigoode Dec 16 '11 at 19:17
up vote 1 down vote accepted

The only solution I found was reformating the server. Not the best answer, but due to time constrains I couldn't do anything else.

share|improve this answer

0 rows affected is normal for a grant.

Did you try doing FLUSH PRIVILEGES after running your grant?

-- EDIT --

I just noticed the date on this question. I'm guessing this is already fixed :)

Maybe this will help someone else...

share|improve this answer
Yes I did. I couldn't find any help to I simply re formatted the server machine. – Johnny Bigoode Feb 3 '12 at 15:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.