Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have cent OS with XEN installed on a blade server. After installing Cent OS I changed its Volumegroup from VolGroup00 to VolGroup01 using command 'vgrename' as I needed to access the Volgroups of VMs I was going to install on this base cent os. After this everything worked fine, and I achieved my objective. But this weekend there was power shutdown in our lab and today when booted these blade servers, CentOSes installed on them are not coming up. Error was 'could not found VolGroup00, unable to locate */dev/root*'. So system was rebooting again and again.

From this error I realized that in boot path it would still VolGroup00 and that's what causing the problem. So at the time of booting by editing kernel lines I changed VolGroup00 to VolGroup01. But this time it threw error which said, 'Found Volgroup01, could not find VolGroup00 and could not locate /dev/root. I can't understand why it is still searching for VolGroup00.

There must be some mapping which still points to VolGroup00 for the location of /dev/root. I think it is in /etc/fstab which ideally should be changed by 'vgrename' command but somehow it didn't. So can I solve my problem? If yes, How?

share|improve this question

2 Answers 2

You will need to update the path to the root filesystem device in /boot/grub/grub.conf as well as for all filesystems in /etc/fstab.

You might be able to boot to single-user mode by editing the GRUB entry when it loads. When you get the bootloader menu, hit <TAB> then correct the root= entry, adding single at the end.

Once you get to a root shell, re-mount the root filesystem as read-write: mount -o rw,remount / and correct /etc/fstab. If /usr is a separate filesystem you'll need to mount this too, to get access to any editors.

share|improve this answer
    
I have tried this already. It doesn't even boot in single user mode with changing the root path. –  stillStudent Dec 20 '11 at 6:55
    
"It doesn't boot" isn't very useful. Does the kernel load? How far does it get? –  James O'Gorman Dec 20 '11 at 7:26
    
Xen kernel is getting loaded, it failing when it starts scanning for physical volumes. It says could not find /dev/root –  stillStudent Dec 21 '11 at 6:54
    
I was able to access cent os file system by booting it in rescue mode. I rectified the entry in 'fstab'. It now looks like /dev/VolGroup01/LogVol00 / ext3 defaults 1 1. I also changed entry in grub.conf and rebooted the system but still got the same error. It says '/dev/root' not found and VolGroup00 not found. It also says VolGroup01 found. I think this /dev/root is created by fstab entry which I mentioned. If yes, then why it is not able to find /dev/root. And if this /dev/root is different and created by something else, then how to create it? –  stillStudent Dec 21 '11 at 12:07
    
If root is on the VG, don't forget to update the initramfs! mkinitrd -f -v /boot/initramfs-$(uname -r).img $(uname -r) –  Christopher Markieta Oct 22 at 0:42

Try to boot with the standard (non-xen) kernel.

Then re-make the initrd. xen needs to know where the root-partition is, too.

I never had this issue with a xen-kernel. With a non-xen-kernel the solution outlined by James should work.

The reason why this does not work with xen seems to be: The XEN-Hypervisor is loaded instead of the Kernel. After that the Hypervisor loads the initrd and the kernel for the Dom0 (so the Dom0 is the first VM) and starts the initrd.

This is in effect similar to a normal boot, but not equal to it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.