Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Have scoured the board but can't seem to find anything that's helped yet.

If I go to http://localhost/ it's fine, if I go to http://localhost/phpmyadmin I get an 'Error 500: Internal Server Error'

There doesn't seem to be anything that'll show up in the log files either. I've tried the RewriteLog as mentioned in PHPMyAdmin 500 Internal Server Error - But that doesn't really seem to help either, nothing gets written to it when I've got:

# Logfiles
ErrorLog  /home/www/beta.**.com/logs/error.log
CustomLog /home/www/beta.**.com/logs/access.log combined
RewriteLog /home/www/beta.**.com/logs/rewrite.log
RewriteLogLevel 9

I've tried uninstalling the package and re-installing it, but that's not helped either. Anyone got any other suggestions? I'm running Debian and Apache 2.

share|improve this question

closed as off-topic by Jenny D, mdpc, Sven Mar 20 '15 at 12:57

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Sven
  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – Jenny D, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

Further to this, I've been through index.php and it dies after loading the required file - Which subsequently dies after the following lines (Line 538): /** * @global PMA_Config $_SESSION['PMA_Config'] * force reading of config file, because we removed sensitive values * in the previous iteration */ $_SESSION['PMA_Config'] = new PMA_Config('./'); – christian.thomas Dec 19 '11 at 14:14
up vote 0 down vote accepted

Ok, so I resolved it by changing Line 538 to the full path, I.E. /etc/phpmyadmin/ - Not 100% sure why, but it does.

share|improve this answer
In your config, you used ./ which takes the file from the current directory - and doesn't do any searching. When you change that to the full path, then PHP knows where to find it. Also: since we can't see your configuration file, line 538 is meaningless. – Mei Dec 20 '11 at 15:50
Line 538 was this line: $_SESSION['PMA_Config'] = new PMA_Config('./'); I'm aware that it'll just take it from the current directory, it just seems weird that a fresh out of the box install oh PHPMyAdmin would use that path.. Presumably the PMA_Config function should do something with the path which it wasn't necessarily doing.. – christian.thomas Dec 20 '11 at 15:54

I faced this problem in localhost and I tried to do many things to solve this problem and I figure out that I had to uninstall server and re-install it and everything works fine now.

Before you uninstall server copy all the database from here C:\server\bin\mysql\mysql5.6.12\data to save folder. Because after the new install he will remove all the old database because it removes the old phpmyadmin and put a new one.
I know this reply is late but i want to give some help.

share|improve this answer
OP does not mention WAMP anywhere in the question.. – Frederik Nielsen Mar 19 '15 at 11:49
sorry i did not mean it i will remove it now – elaz Mar 20 '15 at 10:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.