Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How to set locale in Debian 6.0.3?

$ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE=C
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
$ sudo dpkg-reconfigure locales
[sudo] password for foobar: 
locales-all installed, skipping locales generation
*** update-locale: Error: invalid locale settings:  LANG=en_US.UTF-8
$
share|improve this question

1 Answer 1

up vote 4 down vote accepted

Try running locale-gen - this will re-compile a list of all available locales.

share|improve this answer
    
It worked. Any idea how it got messed up at the first place? How did you know it was broken locale file? Or was it? –  Computist Dec 20 '11 at 4:21
    
I've come across that once before on my own Debian installs; For some reason or another there's a list of 'available locales' that never got generated; as to why is beyond me. –  thinice Dec 20 '11 at 4:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.