Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

my goal is to change the file type php parses, from .php,.phtml,etc to .html. with previous versions of apache2 i'd just edit mod-php5.conf and set:

<FilesMatch "\.html$">
        SetHandler application/x-httpd-php
</FilesMatch>

now on apache2.2.21 that came with debian-testing, it's using input filters...

<FilesMatch "\.html$">
   SetInputFilter PHP
   SetOutputFilter PHP
</FilesMatch>

i changed the file types to .html as you can see above, stop and restarted the server. And it's still only parsin .php files as php.

what am I missing here? the docs doesn't mention anything special for the FilesMatch tag when using SetInputFilter

update: just noticed it's loading a new php module, libphp5filter.so, obviously to take part on the apache2 filter interface.

share|improve this question

migrated from superuser.com Dec 20 '11 at 3:31

This question came from our site for computer enthusiasts and power users.

    
i tried to simply use the previous syntax altogether on the conf file, still no luck –  gcb Dec 20 '11 at 2:36
1  
removing the condition around the loading of the filterIn filterOut solved it. the second code i pasted above had <ifModule...> i simply removed it and now i can change the settings just fine. will try to reproduce and report proper debian-sid bugs if it's the case. –  gcb Dec 20 '11 at 3:15
    
probably closed, but i can't answer my own question because of the site karma thingy –  gcb Dec 20 '11 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.