Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This weekend Exchange 2010 stopped working with Outlook clients. Researching the problem I found out that the Exchange RPC Client Access Service is not starting. Looking at the event log this is what I get:

Message: Failed to register service principal name ExchangeMDB. Failed with error code The specified account does not exist (1317).

Source: MSExchangeRPC

Event ID: 1002

I already checked for ExchangeMDB and its is registered in AD pointing to the right box.

Any ideas on how to solve this problem?

share|improve this question
1  
First of all, check SPN's for the CAS server: from an elevated command prompt run setspn -L [CAS Server name]. Second, try to change the Log On as account for the RPC Client Access Service to LocalSystem and try to start it –  Mathias R. Jessen Dec 29 '11 at 2:40
add comment

1 Answer

up vote 0 down vote accepted

It seems the problem was not related to any Exchange functionality. It seems a GPO was changed for the OU containing the exchange server account and Network Servive or Local System were having problems starting the service. We have moved the server to a different OU and the problem is gone.

I will try to update on what in GPO was affecting those accounts later.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.