Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to redirect all http traffic to https as the site requires SSL.

For example, if someone navigates to http://site.com or http://www.site.com I want to redirect the user to https://www.site.com

Right now the user gets a 403.4 Forbidden error - The page you are trying to access is secured with Secure Sockets Layer (SSL).

I've tried a number of different URL rewrite rules but none of them seem to work. In fact nothing seems to be happening different at all, almost like the module isn't even working properly.

First, is my rule correct? And if so, what else could be preventing this from working properly?

    <rewrite>
        <rules>
            <rule name="Redirect all http traffic to https" enabled="true" stopProcessing="true">
                <match url="(.*)" ignoreCase="true" />
                <conditions>
                    <add input="{HTTPS}" pattern="off" />
                </conditions>
                <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" appendQueryString="true" redirectType="Permanent" />
            </rule>
        </rules>
    </rewrite>
share|improve this question
1  
Your condition is expecting the input to be {HTTPS}. Try removing that condition. –  Tim Dec 20 '11 at 15:01
    
Just remove the condition or change it? –  Tom Dec 20 '11 at 15:06
1  
I would just remove, it is asking for a condition you do not need. –  Tim Dec 20 '11 at 15:07
    
Thanks, unfortunately IIS is still not redirecting after removing that condition. –  Tom Dec 20 '11 at 15:09

1 Answer 1

up vote 1 down vote accepted
<rule name="Redirect to HTTPS" stopProcessing="true">
  <match url="(.*)" />
  <conditions>
    <add input="{HTTPS}" pattern="^OFF$" />
  </conditions>
  <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="SeeOther" />
</rule>

And SSL needs to be off apparently.

Not sure if the and tags are appropriate.

share|improve this answer
    
Yeah, that was the hold up. I had require SSL checked. Once I unchecked it, the URL rewrites fired correctly, thanks. –  Tom Dec 20 '11 at 15:57
    
Just to add to an old thread.... I had same issue, yet SSL was unchecked So I checked it.. apply Uncheck .... apply Works now like a charm –  NeoIsTaken Jul 18 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.