Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't seem to be able to have multiple administrators connect to Windows Server 2008 R2 Standard. Each time a different administrator logs in, it takes the current session away from the user and gives it to them and boots the original user from the server.

I've also tried connecting 1 instance normally and a 2nd with the /admin flag on remote desktop and that didn't matter either.

share|improve this question
5  
Your problem is that you seem to have a bad security practice of sharing an admin account. You should create per-user accounts, so you know who screwed things up. Stop doing that. –  Zoredache Dec 20 '11 at 18:01
    
@Zoredache and there things that matter, and things that matter more. This is not one of the ones that matter more. –  Chris Marisic Dec 20 '11 at 18:33
1  
@ChrisMarisic Obviously everyone's organization is different, but this is pretty basic. If an auditor were to come in and you fail an audit - or if data was compromised/stolen by a malicious admin- you would have no way to prove that it was the other guy and not you. This is an easy way for everyone to lose their job instead of just one bad apple and it should take no more than 5 minutes to configure. –  MDMarra Dec 20 '11 at 18:43
    
@ChrisMarisic, so now you are at a point were the standard Windows functionality makes sharing a admin account a big PITA, it is time to seriously consider modifying your practices to be more in-line with what is more common, since it will work better. –  Zoredache Dec 20 '11 at 18:53
    
@Zoredache it's been on the list, with how 2008 handles the rdc sessions however it just moved a few steps up the list. –  Chris Marisic Dec 20 '11 at 20:35

3 Answers 3

up vote 1 down vote accepted

Shared accounts are a audit nightmare and security risk. That being said.. If you must use the same account for multiple users

Check the Group Policy for "Restrict each user to a single session setting"

Changes to remote administration in Windows Server 2008

Reconnecting to your existing physical console session is controlled by the "Restrict Terminal Services users to a single remote session" Group Policy setting, available in the Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Connections node of the Local Group Policy Editor. You can also configure this setting in the UI by using Terminal Services Configuration. (The Restrict each user to a single session setting appears under Edit settings, in the General section.)

share|improve this answer

It is not about administrative sessions, it is about the user. Unless you reconfigure it the new default is only one session PER USER.

There was an issue with the old approah that sometimes the server would not recognize it is a reconnect so an admin would run out of sessions.

I suggest you just dont run multiple conections - ON ONE ACCOUNT. Create separate accounts per administrator, as is best practice anyway.

share|improve this answer

Without any RDS licensing, Windows Server 2008 R2 allows for two concurrent connections for management from two different users. If you have two users sharing an administrative account, when one logs in he will "hijack" the open session of the other admin unless he explicitly connects to a new session, which is not the default RDP behavior.

share|improve this answer
    
This is changed from how server 2003 behaves that allows multiple administrators to connect to the same machine? –  Chris Marisic Dec 20 '11 at 18:08
    
No, this is the same. In 2003 and 2008(R2) you can have two simultaneous management connections via RDP. The problem is that you can never have two users connecting to manage the same server with the same user name. You'd need two separate accounts for two separate connections in both cases. –  MDMarra Dec 20 '11 at 18:11
    
I swear it's always let me have 2 different sessions for 2 different users logged in as administrator on 2003. If it really doesn't I guess I could only be remembering a console session as the 2nd session. –  Chris Marisic Dec 20 '11 at 18:22
    
Actually, upon further review, it looks like this is a change from the default behavior of 2003. –  MDMarra Dec 20 '11 at 19:35
    
I was really sure I had done this on 2003, this post started to make me question my sanity. –  Chris Marisic Dec 20 '11 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.