Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not using legacy adapters, and i've installed Linux Integration Components 3.2.

THe problem i'm facing is that the command 'setup' or 'system-config-network' doesn't list any network interfaces. If i run ifconfig -a i can see both the network cards i've attached. By setting a ip using ifconfig i can get network connectivity. The problem is that it's not persistent after a reboot.

I'm a 100% centos newbie, but I figure it has something to do with that the centos installer couldn't see the NICs on install.

How can I fix this?

share|improve this question
add comment

5 Answers

In my case once I added the integration services I went in and created the ifcfg-eth0 file with the following

DEVICE=eth0 BOOTPROTO=dhcp HWADDR=(fill in yours) ONBOOT=yes

then I ran system-config-network and added my DNS servers (this may not have been necessary)

once I did that and restarted the network service it started responding to CentOS 6.3 .

This was under HyperV built into Windows 8 Enterprise

share|improve this answer
add comment

Have a look in /etc/sysconfig/network-scripts/ifcfg-eth0 there should be a line that says ONBOOT=yes which causes eth0 to be configured when the system starts.

share|improve this answer
    
There's no such file. But creating it with Device=eth0 and restarting /etc/init.d/network made it visible for system-config-network so now it's working :) –  LonelyLonelyNetworkN00b Dec 20 '11 at 19:47
add comment

Adding to lain's answer..

I'm running Hyper-V, CentOS 6.2.

  1. When initially setting up your VM for CentOS, do the "delete the network adapter...add a legacy adapter" like everyone says.
  2. AFTER that, install CentOS
  3. Upon first boot, run system-config-network. You should see eth0. Edit it.
  4. eth0 should show it is set to DHCP ... [*]. I changed my to static.
  5. cd /etc/sysconfig/network-scripts
  6. ifup eth0 (run it)...it should take a moment while the interface initializes
  7. Try to ping your gateway.
  8. Follow lain's instructions to get your eth0 to start at boot.
share|improve this answer
add comment

CentOS (like almost all modern *nix OSes) uses a set of configuration scripts at startup to configure various parts of the system including network configuration scripts/files.

You can manually edit the relevant file to configure each of the synthetic NICs when the system boots.

share|improve this answer
add comment

The trick seems to be to run the command 'system-config-network' at a shell prompt as root after you've installed the Linux Integration Services. On my CentOS 6.2 instance it detected the virtual network adapter and after I saved my configuration changes and did a reboot I was on the road.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.