Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The remote server is running CentOS 5.5.

I have created an rsa key from my client server, and copied it into /home/hadoop/.ssh/authorized_keys. This worked fine - I can ssh to hadoop@remoteserver without being prompted for a password.

I also have a data user on remote server that I want to ssh into. I copied the exact authorized_keys file over to the data user's home directory, but cannot ssh in. I believe the permissions are set correctly - when I do ls -al in /home/data/.ssh on the remote server, it shows:

drwx------  2 data data 4.0K Dec 20 12:52 .
drwxrwxr-x 26 data data 4.0K Dec 20 12:52 ..
-rw-------  1 data data  405 Dec 20 12:58 authorized_keys
-rw-------  1 data data  736 Oct 24 17:18 id_dsa
-rw-r--r--  1 data data  607 Oct 24 17:18 id_dsa.pub
-rw-------  1 data data 1.7K Dec 20 10:51 id_rsa
-rw-r--r--  1 data data  399 Dec 20 10:51 id_rsa.pub
-rw-------  1 data data 5.2K Dec 20 10:40 known_hosts

Is there anything I'm overlooking? Any advice is much appreciated.

EDIT: Does the user's group matter at all? (I would imagine not, since permissions are 0 for group, but thought it may be relevant). data user is in a different primary group:

$ id data
uid=1350(data) gid=1350(datausers) groups=1350(datausers)

However, I just tried cd ~/; chown -R data:datausers .ssh, and it still asks me for a password when I try to ssh in.

EDIT2:

$ ssh -vvv data@remote-server
OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to remote-server [192.168.5.208] port 22.
debug1: Connection established.
debug1: identity file /home/data/.ssh/identity type -1
debug3: Not a RSA1 key file /home/data/.ssh/id_rsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/data/.ssh/id_rsa type 1
debug3: Not a RSA1 key file /home/data/.ssh/id_dsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/data/.ssh/id_dsa type 2
debug1: loaded 3 keys
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_init: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 129/256
debug2: bits set: 522/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: filename /home/data/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 1
debug3: check_host_in_hostfile: filename /home/data/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 1
debug1: Host 'remote-server' is known and matches the RSA host key.
debug1: Found key in /home/data/.ssh/known_hosts:1
debug2: bits set: 523/1024
debug1: ssh_rsa_verify: signature correct
 debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/data/.ssh/identity ((nil))
debug2: key: /home/data/.ssh/id_rsa (0x2aef897453e0)
debug2: key: /home/data/.ssh/id_dsa (0x2aef897454a0)
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug3: start over, passed a different list publickey,gssapi-with-mic,password
debug3: preferred gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup gssapi-with-mic
debug3: remaining preferred: publickey,keyboard-interactive,password
debug3: authmethod_is_enabled gssapi-with-mic
debug1: Next authentication method: gssapi-with-mic
debug3: Trying to reverse map address 192.168.5.208.
debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug2: we did not send a packet, disable method
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/data/.ssh/identity
debug3: no such identity: /home/data/.ssh/identity
debug1: Offering public key: /home/data/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Offering public key: /home/data/.ssh/id_dsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
data@local-server's password: 
share|improve this question
1  
Please edit your question and provide verbose output: ssh -vvv data@server –  kubanczyk Dec 20 '11 at 18:35
    
Also, keep in mind... just because it works on server A & is properly configured on server A... does not imply that server B is configured for key-based authentication. –  TheCompWiz Dec 20 '11 at 18:41
    
@TheCompWiz - Sorry if that was unclear, there is only one remote server. Just trying to (passwordlessly) ssh in as a different user on that server. –  danny Dec 20 '11 at 19:18
    
Well... honestly, I do this every-day. The only 2 bits are a) public key in authorized_keys in users' home dir, b) ssh user@host. It's not that complicated. You may need to check the "auth" log for more information. –  TheCompWiz Dec 20 '11 at 19:21
    
@kubanczyk - added the verbose output –  danny Dec 20 '11 at 19:35
show 1 more comment

2 Answers 2

How was your ssh key created? Appears the key file may not be in a proper format.

debug3: Not a RSA1 key file /home/data/.ssh/id_rsa

Perhaps something was bungled in the copy paste. I would need to check the docs but SSH keys I use typically do not have BEGIN lines.

share|improve this answer
    
I'll try re-generating the RSA1 key when I get a chance tomorrow. Curious that it might work with one user and not another, but if those warnings aren't normal I'll look into it. –  danny Dec 20 '11 at 23:10
add comment

You are using local /home/data/.ssh/id_dsa to match the remote /home/data/.ssh/authorized_keys. This means you've attempted to ssh from user data to user data.

When you've successfully connected to hadoop (using /home/hadoop/.ssh remotely) have you used local /home/data/.ssh/id_dsa (user data) or some other local user?

share|improve this answer
    
I've used /home/data/.ssh/id_rsa - so the local data user. Literally just a matter of ssh data@remote-server vs ssh hadoop@remote-server, both when I am the data user on local server. –  danny Dec 20 '11 at 23:08
    
No idea. Compare proper logs with ssh -vvv hadoop@remote-server maybe there would be some difference that would give you a clue. –  kubanczyk Dec 22 '11 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.