Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Windows is notifying me that there is an IP conflict with the address 192.168.1.2 (the IP of my domain controller), with a device with hardware address corresponding to my Linksys WRVS4400N v1.1 wireless-n router.

This device's LAN IP is 192.168.1.1. No problems there.

I can't find any trace of 192.168.1.2 anywhere in its GUI config, except for port forwarding rules. This is just a small-business level wireless router; not a heavy Cisco device with the option to assign multiple interface addresses.

However, that's just what it seems to be doing: when I dump its config and look ctrl+f for the IP in question, I find this line:

    lan_ifnames=etho0 wl0
    wl_chip_ip=192.168.1.2
    wlan_mgr_enable=1
    wl0_ssid-linksys-n

Of course, my real SSID isn't "linksys-n", but that's what the config file shows.

So without changing the IP of my domain controller, is there a way to change this obscured "wl_chip_ip" address?

Viewing the arp table for the network shows that the router is squatting on both IPs:

    Internet Address        Physical Address 
    192.168.1.1             00-1c-10-f6-8d-2c 
    192.168.1.2             00-1c-10-f6-8d-2d

But pings are replied to by the server (determined by turning windows firewall on/off).

The only impact of this issue is that Windows keeps logging IP conflicts; nothing else seems to be impacted.

share|improve this question
    
What port forwarding rules? If the router think it's supposed to forward traffic for 1.2, it will respond to arp broadcasts for that IP with its own mac. –  Paul Ackerman Dec 20 '11 at 19:03
    
Hi Paul, these are the kind of port forwarding rules in simple router that allow external traffic to private IP addresses, where the TCP port type is "n". It only works one way, from the outside in- or so I thought. The router does not appear in the arp list from any PC on the LAN with this phantom IP. However, it does appear in the arp list for wireless clients. Internet Address Physical Address 192.168.1.1 00-1c-10-f6-8d-2c 192.168.1.2 00-1c-10-f6-8d-2d Is this expected behavior? It appears the router is squatting on this IP. –  ndespres Dec 20 '11 at 19:14
    
Curious how you are "dumping" the config on that thing. Are you possibly dumping information from it's read only boot rom? Those may be the factory settings you are seeing, not the current "running" settings. Disconnect everything and then connect a single device (laptop?) and ping the IP address in question. That will clear some stuff up. –  Tim Dec 20 '11 at 19:19
    
Regardless of where you saw it in the config, if it's showing up on clients with that mac, it is definitely active. Although, for the DC to be complaining, it must be showing up on LAN clients too not just wireless... Go through the WAN, LAN and WLAN settings and triple check that it isn't configured anywhere with that IP. –  Paul Ackerman Dec 20 '11 at 19:51
    
Tim, I'm using the RVS's config backup feature. It saves a copy of the configuration to a file on your PC, so you can copy the config to another device or recover in the event that you botch your firmware update. When I disconnect everything and connect only my laptop, I only see 2 arp entries, just like the above comment- the router on 2 IPs. –  ndespres Dec 20 '11 at 19:53

1 Answer 1

up vote 1 down vote accepted

I had the same issue. The reported MAC ID was +2 (NOT +1) higher than the MAC listed on the device. There is an option under Setup/LAN in the Config Tool: "IP Reserved for Internal Usage: 192.168.1.[2] (Range: 1 .. 254 )"

share|improve this answer
    
Digger, I don't know how I missed this- there's an option under Setup>LAN called "Wireless local IP address" which was set to .2. –  ndespres Dec 30 '11 at 16:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.