Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The problem is not a persistent one; it happens sometimes and I am unable to recreate it (even using the same urls).

[Tue Dec 20 09:07:12 2011] [error] [client 66.249.66.169] (20025)The given path contained wildcard characters: access to /?p=2463 failed

[Tue Dec 20 10:10:30 2011] [error] [client 110.0.107.198] (20025)The given path contained wildcard characters: access to /proxyimages.php?url=http%3A%2F%2Fi.imgur.com%2F2DKZ0.jpg&mimeType=image%2Fjpeg failed

I am using a Wordpress blog with some modifications, and since a while a go i have been getting a lot of those errors from apache, and google results for this problem aren't helpful...

Any ideas?

EDIT:

Some virtual hosts are only thing different from the clean httpd.conf

<VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/
    ServerName 94.102.49.102    
</VirtualHost>


<VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/site1
    ServerName www.site1.com
    ServerAlias site1.com *.site1.com
</VirtualHost>


<VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/site2
    ServerName www.site2.info
    ServerAlias site2.info *.site2.info
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/site3
    ServerName www.site3.com
    ServerAlias site3.com *.site3.com
</VirtualHost>

And the .htaccess generated by wordpress

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
share|improve this question
    
What version of Apache and OS are you using? A quick search suggests this is a Windows related issue but useful to include those version details to get better help. –  jeffatrackaid Dec 20 '11 at 21:43
    
Thanks for the response. Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 Windows Server 2003 –  Ivan Castellanos Dec 21 '11 at 5:10
    
Can you describe those modifications if possible? –  Khaled Dec 23 '11 at 17:18
    
The modifications are just a few... BTW, i am ussing XAMPP latest version. –  Ivan Castellanos Dec 24 '11 at 18:18
    
Please include any rewrite rules (like permalink rewrites) that is configured in apache (like in .htaccess, vhosts.conf or httpd.conf) –  Mathias R. Jessen Dec 26 '11 at 3:32
add comment

2 Answers

The problem is that there is a character that is being inserted into URLs that needs to be escaped or removed. Some rule somewhere in apache is placing that character. You must take into account any rewrite rule or AliasMatch rule.

Copy your existing httpd.conf file and put a vanilla conf in its place. See if the problem exists. diff the two files and start adding blocks back in one at a time and testing your server. If you use mod_alias, disable that and see if the problem persists. It's also possible that you're inheriting some troublesome regex in an .htaccess file somewhere. Check those and rule out any possibility there.

Once you've narrowed the issue down, you can report back and we can be of more help.

Edit 1

This is sounding like an application error. It could be something with one of your Wordpress plugin. The errors suggest that something is throwing unescaped characters into your URLs. Perhaps a decodeURI function. Of primary concern is any rewriting that is happening to pull in files and documents that are outside of the web server's document root.

Disable all plugins in your wordpress installation and check for errors. Add them back in one at a time and see when the errors resurface.

share|improve this answer
    
The problem is not a persistent one; it happens some few times and i am unable to recreate it (even using the same urls). I just added more info in the original question; thank you. –  Ivan Castellanos Dec 28 '11 at 22:00
add comment

The 5th line in your .htaccess file looks funny. Also, afaik, it's not part of the default permalink rewrite ruleset in wordpress. Try removing (or just commenting out) the line. this is the one I'm talking about:

RewriteRule ^index.php$ - [L]

Also, as it is a [L]ast rule, the rest is deferred after this rule is processed, so it would not make sense to have them there it that line was intended. Please remove it and let us know about the result

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.