Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up PPTP server with Debian Squeeze.

The problem is nothing is being written in the logs (neither in messages nor in debug nor in daemon.log) though debug and dump options are set. The only line I get after pptpd restart is:

# tail -n 1 /var/log/daemon.log
Dec 21 00:25:09 vpn pptpd[1965]: MGR: Manager process started

The daemon starts, the port is listened and available to connect. But no logs... I've tried to find pptpd-dbg but debian has no such package. Any ideas on what's wrong with my config? pptpd or rsyslog ones. Is there any way to get pptpd debug output on stdout?

pptpd version 1.3.4-3 (set up from stable repository)
rsyslog version 4.6.4-2 (set up from stable repository)

Configurations: pptpd.conf

# egrep -v '^#.*' /etc/pptpd.conf  | egrep -v '^$'
ppp /usr/sbin/pppd
option /etc/ppp/pptpd-options
debug
logwtmp
delegate

pptpd-options

# egrep -v '^#.*' /etc/ppp/pptpd-options  | egrep -v '^$'
name vpn
domain example.com
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
nomppe-40
nodefaultroute
debug
dump
lock
nobsdcomp 
auth

rsyslog.conf

# egrep -v '^#.*' /etc/rsyslog.conf  | egrep -v '^$'
$ModLoad imuxsock # provides support for local system logging
$ModLoad imklog   # provides kernel logging support (previously done by rklogd)
$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
$FileOwner root
$FileGroup adm
$FileCreateMode 0640
$DirCreateMode 0755
$Umask 0022
$IncludeConfig /etc/rsyslog.d/*.conf
auth,authpriv.*                 /var/log/auth.log
*.*;auth,authpriv.none          -/var/log/syslog
daemon.*                        -/var/log/daemon.log
kern.*                          -/var/log/kern.log
lpr.*                           -/var/log/lpr.log
mail.*                          -/var/log/mail.log
user.*                          -/var/log/user.log
mail.info                       -/var/log/mail.info
mail.warn                       -/var/log/mail.warn
mail.err                        /var/log/mail.err
news.crit                       /var/log/news/news.crit
news.err                        /var/log/news/news.err
news.notice                     -/var/log/news/news.notice
*.=debug;\
        auth,authpriv.none;\
        news.none;mail.none     -/var/log/debug
*.=info;*.=notice;*.=warn;\
        auth,authpriv.none;\
        cron,daemon.none;\
        mail,news.none          -/var/log/messages
*.emerg                         *
daemon.*;mail.*;\
        news.err;\
        *.=debug;*.=info;\
        *.=notice;*.=warn       |/dev/xconsole
share|improve this question

2 Answers 2

up vote 1 down vote accepted

I'm sorry... Packet filter misconfiguration.

pptpd begins to write to the log file only when it receives a connection. IMHO it should dump the configuration earlier, at start but that's not the topic of the question.

share|improve this answer
    
I didn't have rsyslogd installed! Doh. dabase.com/blog/pptpd_VPN_iPhone –  hendry Dec 27 '12 at 5:51

Is /var/log/debug also empty? Try adding kdebug 1 to pptpd-options. To see pptpd output, run

pptpd -d -f -c /etc/pptpd.conf
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.