Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

HBase stable is currently hbase-0.90.4, what version(s) of HDFS is it compatible with?

share|improve this question
add comment

1 Answer

The answer is hadoop-0.20.205.0 but you also need to replace jar files in ./lib/ of HBase with the ones of your working HDFS installation.

For me it was:

rm /opt/hbase-0.90.4/lib/hadoop-core-0.20-append-r1056497.jar
cp /opt/hadoop-0.20.205.0/hadoop-core-0.20.205.0.jar /opt/hbase-0.90.4/lib/
cp /opt/hadoop-0.20.205.0/commons-configuration-1.6.jar /opt/hbase-0.90.4/lib/

In addition, you should to add the following to your HDFS and HBase configuration on all the nodes:

<property>
  <name>dfs.support.append</name>
  <value>true</value>
</property>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.