Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to mount a nfs network share in various OSs (ubuntu 10.10/10.10 server/11.10) but continually get the same error:

mount.nfs: access denied by server while mounting 128.251.xxx.xxx:/Systems

I have verified that I have nfs-common installed on my machine. And my /etc/fstab mount command is as follows:

128.251.xxx.xxx:/Systems /home/me/uslonsnas001 nfs async,rw,hard,intr 0 0

The network device is a Seagate NAS, here are some screenshots of the device setup (through the web interface).

Verify that NFS is enabled for the share point named 'Systems' enter image description here

Verify that NFS service is enabled on the device enter image description here

Verify the share is set to enable public access: enter image description here

So what else could I be missing to make this mount work?

share|improve this question

2 Answers 2

Generally there are permissions associated with NFS exports, i.e. hosts that are allowed to access NFS according to the server (in this case, your NAS).

A traditional export file that allows all hosts to access the export (aka share) looks as follows:

/foo/bar *(ro,sync)

* means all hosts, so you probably want to look for something similar in the GUI of your NAS

share|improve this answer
    
I understand - but since I cannot get into the CLI of the device how would I access this? Plus, one (web-interface) config section I forgot to post says the volume is read/write enabled for public access. I added another image to my OP to show this setting. –  sadmicrowave Dec 21 '11 at 18:57
    
is there a way to nfs to a mount point by setting a username and password? –  sadmicrowave Dec 21 '11 at 19:02
1  
showmount -e yournasiporhostname will show the export list and options. If it's not being exported to your client or there's a problem with the path it will turn up here. –  Aaron Copley Dec 21 '11 at 19:25

I just figured out my problem!

Found in this thread: http://forums.seagate.com/t5/BlackArmor-NAS-Network-Storage/Unable-to-nfs-mount-from-BlackArmor-440/td-p/28522

It seems that Seagate exports its NFS shares by first specifying the data-volume the share is found on (while when using CIFS, you can shorthand the path)

CIFS mount path:

 128.251.xxx.xxx:/Systems

NFS mount path:

 128.251.xxx.xxx:/DataVolume/Systems

such a simple stupid problem - very little documentation out there about it though - hope this helps someone else.

share|improve this answer
    
Go ahead and accept your own answer. :) –  Aaron Copley Dec 21 '11 at 19:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.