Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im using Cacti to try to monitor our network: www.cacti.net

My graphs are just showing broken image links. I have just installed cacti version 0.8.7i for windows XP. Running RRDTools 1.4.5, and even went down to version 1.2.x

I went to the system utilities link in cacti and selected "Technical Support" everything appears to be good except the section that says RRDToolVersion:

"Error: Installed RRDTool version does not match configured version. Please visit the configuration settings and select the correct RRDTool Utility Version."

So I went to the configuration settings and the RRDTool utility version is set to RRDTool 1.2.x

I also checked the "Paths" tab in the configuration settings and everything looks good there, the only one that seems odd is the RRDTool Default Font. Other then that the paths look ok.

Here is my log file: enter image description here

Here is a screen shot of a graph in debug mode: enter image description here

Here is a screen shot of the settings: enter image description here

EDIT

More info here...http://forums.cacti.net/viewtopic.php?f=3&t=46157&p=224854#p224854

Still no luck :(

share|improve this question
    
Perhaps a dumb question, but what happens when you run the RRDTool command from debug mode yourself? Does it create a valid graph image? –  Handyman5 Dec 29 '11 at 18:47
    
@Handyman5 - i can run the rrd command from a command line but how can I view the actual graph??? Its an unknown file type –  JonH Dec 29 '11 at 19:45
    
The image viewer IrfanView can handle just about any image in existence and is free. –  Handyman5 Dec 29 '11 at 19:49
    
grab that debug rrdtool text. Change the "-" in the first line (after graph) to "c:\temp\test.png". If that doesn't produce an image change graph to graphv in that first line and run it again. report the output and if you can view that .png file with your browser. –  Mark Dec 30 '11 at 17:37
    
@Mark - do you mean rrdtool graph c:\temp\test.png ? If so in the command window I get 0x0 –  JonH Dec 30 '11 at 17:53

2 Answers 2

up vote 1 down vote accepted

You can still run rrdtool.exe dump filename.rrd output-filename.xml and see if there is any data in the RRD files, if they exist. It is harmless and lets you know if the poller part is actually doing its job correctly.

If the RRDs exist, but you are still getting errors then some part of PHP's library stuff may be unhappy. We had an issue with our CACTI install and wound up rolling back to an older version of RRDTool. Grab the newest 1.2.x version from http://www.cacti.net/downloads/rrdtool/win32/ and get it installed.

Make sure you install it in C:\rrdtool (back up the other install) and then make sure that Cacti has "RRDTool 1.2.x" set for the RRDTool version setting.

If it still gives you trouble or complains about the RRAs being bad, you may need to delete your hosts and their monitors and rediscover to get the RRD files recreated. IIRC, we had to do that after swapping versions.


Updated again

If all that works, check permissions at the IIS level. Make sure that IIS can run rrdtool and can get to the RRA databases with read access. Check the folder permissions at the cacti level versus the cacti/rra level and make sure it inherits the local IISUSR. Make sure the IISUSR has execute in c:\rrdtool.

And, finally, if you get "GRAPH ACCESS DENIED" then your cacti login account isn't configured to view graphs in the User Management screens. http://docs.cacti.net/manual:087:2_basics.4_user_management#user_management

share|improve this answer
    
I do see RRD files. I do have snmp installed. I tried posting here forums.cacti.net/viewtopic.php?f=3&t=45980 but no answers. –  JonH Dec 29 '11 at 15:00
    
Updated with notes on what we did to get ours working. I don't think the Cacti to RRDTool1.3 stuff actually works on Windows... downgrade RRDTool to known-good is my suggestion. –  Mark Dec 29 '11 at 16:07
    
I downgraded and got rid of some of the error messages but see my edit in my question. I am still getting broken images as graphs. –  JonH Dec 30 '11 at 13:34
    
do you mean rrdtool graph c:\temp\test.png ? If so in the command window I get 0x0 – –  JonH Dec 30 '11 at 18:16
    
see my comments in my original question...getting very close... –  JonH Jan 11 '12 at 17:40

I'm not sure you're having a problem with RRDs. I think you may be having a problem with data collection.

See all the "12/21/2011 10:15:02 AM - CMDPHP: Poller[0] Host[3] DS[10] WARNING: Result from SNMP not valid. Partial Result: U " lines?

That seems to suggest you're not getting the data.

Do you have SNMP enabled on the hosts you're querying?

Have you opened up firewall access to allow SNMP requests?

share|improve this answer
    
Yes I have snmp installed...is there anything I can do to see why it isnt working? I do see .RRD files...I tried posting here with no help forums.cacti.net/viewtopic.php?f=3&t=45980 –  JonH Dec 29 '11 at 15:00
    
I edited my question, this is still not working :(. –  JonH Dec 30 '11 at 13:34
    
I agree with Joel. Can you fetch the appropriate SNMP data with snmpget or snmpwalk? –  James O'Gorman Jan 1 '12 at 20:23
    
I've seen that error before. The "U" is the first character of a much longer and very useful message. Find that error message and you will solve your problem. –  Ladadadada Jan 7 '12 at 18:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.