Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is probably a simple one for all you Unix whiz' out there, but I can't figure it out, so I am trying to sftp into a windows server from the command line, and the remote refuses connection. When I run it in verbose mode, I can see that the system is trying to use one of my public keys (set up in my ssh config and used for another server that I ssh into) for authentication, when all I want is for it to ask me for a password, here is a sanitized version of the trace:

sftp -v<username>@<remote_ip_address>
OpenSSH_5.6p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /Users/Admin/.ssh/config
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug1: Connecting to <remote_ip_address> [<remote_ip_address>] port 22.
debug1: Connection established.
debug1: identity file /Users/Admin/.ssh/id_rsa type 1
debug1: identity file /Users/Admin/.ssh/id_rsa-cert type -1
debug1: identity file /Users/Admin/.ssh/id_dsa type -1
debug1: identity file /Users/Admin/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9
debug1: match: OpenSSH_5.9 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.6
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '<remote_ip_address>' is known and matches the RSA host key.
debug1: Found key in /Users/Admin/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_ACCEPT received

                            ****USAGE WARNING****

<SFTP Banner  Text>

debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/Admin/.ssh/id_rsa
Connection closed by <remote_ip_address>

When I try this on a windows machine with WinScp or Putty, things work just fine. But I need to get this working on my production server (Centos) where I can't install these or another utilities. PS: Im able to reproduce this problem on my mac as well, with the same result, but can't resolve it on either. Any help would be appreciated. Thanks in advance!!

share|improve this question

migrated from Dec 22 '11 at 8:13

This question came from our site for professional and enthusiast programmers.


sftp -o PubkeyAuthentication=no <user>@<server>

That should disable the will of using your public key for this session.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.