Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed wordpress on a Linux server running lighttpd. For installation I accessed wordpress on 192.168.1.2:81/wordpress which is the LAN ip of the server. Installaton was successfull, and at general settings in the wp-admin the url shown was http://192.168.1.2:81/wordpress. After the installation I gave wordpress backend as 127.0.0.1 and port 81 on my Varnish cache running on the same server. This is varnish vcl:

sub vcl_recv { if (req.url ~ "^/wordpress") { set req.backend = default;}}

But I could not access the home page when I used: http://pubip/wordpress. So I changes url in wp-admin as http://localhost:81/wordpress. But still I could not access the home page. Any solution for the issue? I have many python, php apps running over Varnish which work perfectly well, but only wordpress fails.

share|improve this question
    
Were you able to access the home page before you enabled the cache? –  Tim Dec 22 '11 at 17:47
    
Yes. Hardcoding the url in the wp-admin is the issue I guess. If the server has many interfaces connected to separate subnets, then the blog can be a access only from the ip which is specified in the wp-admin settings. But, wp-admin does not accept something like 0.0.0.0. –  nixnotwin Dec 23 '11 at 9:06
    
Yah, I never have found a way around that. –  Tim Dec 23 '11 at 13:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.