Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I need to collect baseline performance data on a SQL Server running on Windows Server 2008 R2. When I open perfmon on my computer running Windows 7 and try to add counters from the remote server, I receive an error stating "Unable to connect to the machine."

I can ping the server, and I can connect using Remote Desktop.

In addition to the perfmon issue, I cannot browse shares (e.g. \uncpath\c$), connect to the remote registry, or connect to port 445 over telnet.

I'm on the same subnet as the server, and the Windows Firewall is turned off on both the server and my computer.

share|improve this question
1  
It may seem obvious, but have you verified there's actually something listening on the target machine? (do connections work from localhost? Does netstat show listeners where you expect them?) -- Assuming everything else you're reporting is accurate the only reason I can think of that you can't connect to this host is that it's not listening... –  voretaq7 Dec 22 '11 at 20:29
    
Doesn't perfmon use RPC or ADMIN$ shares to poll it's data? Is RPC blocked somehow? –  Tim Dec 22 '11 at 21:41
1  
@voretaq7 netstat -ao shows the Service process is listening on TCP 445. When logged into the server, I can establish a connection by typing telnet localhost 445. –  Rob D. Dec 22 '11 at 21:48
    
Any ipsec setting? –  Remus Rusanu Dec 22 '11 at 22:24
    
@RemusRusanu There are no dynamic or static ipsec policies configured on the server (checked using netsh ipsec dynamic show all and netsh ipsec static show all). –  Rob D. Dec 22 '11 at 22:33

1 Answer 1

I know this is old but might as well add some answer to this question for future use...

Make sure you can connect

telnet thehostname 445

Or on linux

 nc -v -w3 thehostname 445
 Connection to test-ws1 445 port [tcp/microsoft-ds] succeeded!

Make sure something is listening

C:\Users\Administrator>netstat -ao | find "445"
  TCP    0.0.0.0:445            thehostname:0             LISTENING       4
  TCP    [::]:445               thehostname:0             LISTENING       4

Make sure file and printer sharing is enabled on that interface

enter image description here

The last one got me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.