Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to use Rsync to transfer files between servers. However, I used a nonstandard port on one of the servers. This caused trouble, so I changed the port back to 22. Now, when I try to use Rsync it still tries to connect to the non standard port. When I use Webmin for SSH, it tells me that the SSH server isn't running on port 22. If I use Putty, everything works fine, so I know it is set up on port 22. Any suggestions on how to get Rsync and Webmin to notice the change? I've restarted the Rsync service multiple times and I am using Ubuntu Server.

share|improve this question
add comment

1 Answer

You can invoke rsync from the command using this form:

$ rsync -e 'ssh -p 22' src user@host:dest

This way you can specify any option you want to ssh. In the above example, you are specifying the port number.

If you are talking about rsync daemon, it listens by default on the port TCP/873 not TCP/22.

share|improve this answer
    
Thanks for the answer. I understand that there is a way to get around it. However, I am wondering why the applications don't recognize the change in ports and what I can do to change that. –  Arthur Dec 31 '11 at 20:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.