Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Once in awhile my 871w loses the DSL connection and the Dialer0 interface goes down. When the atm0 interface comes up, sometimes the Dialer0 interface hangs for 5 minutes or so before redialing. Is there anything I can do to improve the connection time and reduce the downtime? Thanks.

interface Dialer0
 bandwidth 384
 bandwidth receive 2000
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer enable-timeout 1
 dialer wait-for-line-protocol 1
 dialer wait-for-carrier-time 1
 dialer redial interval 5 attempts 65535 re-enable 360
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname username
 ppp chap password 7 01234567890
 ppp pap sent-username username password 7 01234567890
 crypto map mymap
 service-policy output QoS-Output-Wrapper
share|improve this question
    
Could you post a copy of the config from your CLI (if you have access)? I'm curious to see what your ppp keepalive is set to. –  n1reu Dec 26 '11 at 6:58
    
Sure, post updated. –  ensnare Dec 26 '11 at 10:10
    
Related: what is your downstream noise margin, and have you tried reducing the downstream speed until it exceeds 12dB? You quite possibly may be able to achieve a stable connection at 1.5Mbps if you are "almost stable" at 2Mbps. –  Skyhawk Dec 26 '11 at 17:38
    
It's strange -- the noise margin is around 11db during the daytime and goes down to 1-2db at night. How can I force a slower speed? I already set dsl noise-margin 3 in the atm0 interface. –  ensnare Dec 26 '11 at 18:28

2 Answers 2

up vote 1 down vote accepted

Your disable time is set to 6 minutes (360 seconds). You should try to disable the dialer redial option as you have already specified dialer wait-for-line-protocol.

Dialer should redial automatically as soon as both dsl sync (wait-for-carrier-time) and atm layer (wait-for-line-protocol) are up.

Try to do the following:

Router(config)# interface dialer0
Router(config-if)# no dialer redial interval 5 attempts 65535 re-enable 360

You could also increase the timeout on the wait-for option to see if line goes down again:

Router(config)# interface dialer0
Router(config-if)# dialer wait-for-line-protocol 5
Router(config-if)# dialer wait-for-carrier-time 5
share|improve this answer

Under interface Dialer0 try forcing PPP to timeout faster using:

keepalive 10 5

You may need to tweak the numbers, but here is the general command:

keepalive [seconds between ping] [max retries]

The easiest test will be to try adding the keepalive then down the interface and see how long it takes dialer0 to come back up - compare to the pre-keepalive time.

~j

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.