Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Okay ,I am using WAMP and changed mysql password from phpMyAdmin interface of all the root accounts. Now after that i when i tried to access localhost/phpmyadmin - The access was denied and the interface is not ready to show up . Here is the Error

 #2000 - mysqlnd cannot connect to MySQL 4.1+ using the old 
  insecure authentication.Please use an administration tool 
 to reset your password with the command 
 SET PASSWORD =  PASSWORD('your_existing_password').
 This will store a new, and more secure, hash value in mysql.user. 
 If this user is used in other scripts executed by PHP 5.2 or
 earlier you might need to remove the old-passwords flag from
 your my.cnf file.

 phpMyAdmin tried to connect to the MySQL server, and the server
 rejected the   connection. You should check the host, username and 
 password in your configuration and make sure that they correspond to 
 the information given by the administrator of the MySQL server.

Then afterwards i tried using the method given in Reference manual for resetting the password by creating that init.txt file (Hope you all know what i am reffering to here . If not just try this link)

Then following all the instructions clearly the CMD in its output shows some following negative statements:

 [note]plugin 'FEDERATED' is disabled.
 INNODB memory heap is disabled.


 [warning]Invalid password found for "Edited_root_username" @localhost
 [warning]Invalid password found for "Edited_root_username" @127.0.0.1
 [warning]Invalid password found for "Edited_root_username" ::1

 [note]:event scheduler loaded 0 events 

And finally last catchy statement was:

ERROR:You have an error in your sql syntax .please check yor mysql
manual for correct syntax near `FLUSH PRIVILEGES. 

This last line is FUNNY . It is the exact statement mentioned in their own manual for server version 5.5 .

Note: the rootusername that CMD shows is the one that i changed through phpMyAdmin interface. the previous one was of course - root.

Just cant get these MYSQL syntax error . NO idea what to try next ?

share|improve this question
    
That last line is not funny, that is a syntax error - you spelt privileges wrong, it should be FLUSH PRIVILEGES. –  Ben Pilbrow Dec 27 '11 at 14:01
    
My bad,i just mistyped here . Have updated above but still the same exact problems and errors on trying again . –  kushal Dec 27 '11 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.