Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to make web server for high load on Ubuntu. I use nginx for frontend and apache for backend.

And as you probably guessed I was not able to gather Apache (worker) + mod_php + APC, because it is not possible under Ubuntu with apt-get install.

How can I do this?

  • If you want to propose to collect from the source, please give the exact instruction
  • Please do not offer to use fastcgi
share|improve this question
2  
Why no Fast CGI? –  James Butler Dec 21 '11 at 10:28
add comment

migrated from webmasters.stackexchange.com Dec 26 '11 at 19:46

This question came from our site for pro webmasters.

1 Answer

Although, you don't want fcgi, it is the way to go here. Mixing threaded and non-threaded is not very clever.

Not all PHP modules are thread safe and you would want that with MPM worker. You can, if you compile by hand, force it to go together but you will run into problems with it.

The symptoms you will see is Apache blowing up sometimes and segmentation faults.

PHP needs space for execution and you can do that with prefork+mod_php or worker+fcgi.

Yes, I allow myself to post this as an answer, even if I know that this isn't the answer you really want.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.