Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I blocked some IP addresses as described on this page, but it can still access my website.

I know I can block it in IIS7 and that option works, but I would like to block it with the firewall, rather than IIS, so that a 403 is not generated.

Any idea what I have missed?


Update in response to comments:

The firewall is off in Server Manager

Domain profile: Firewall is ON

Private Profile: Firewall is ON

Public Profile is Active: Firewall is OFF

share|improve this question
1  
Is the firewall enabled? –  Chris S Dec 27 '11 at 14:27
    
I figured it, no, if I enable it, would it cut me off? Assuming default settings? I mean do I need to configure it first, or is it safe to turn it on and then add custom rules? –  N_F_S Dec 27 '11 at 14:30
    
I really don't know how you're connected, but more likely than not, yes, it's going to disconnect you unless you enable Remote Administration (for RDP connection) or the File and Print Sharing stuff (for MMC/SMB administration). YMMV, Bridge may be Icy, Caveat Emptor. –  Chris S Dec 27 '11 at 14:35
    
Chris, actually I looked and its on for 2 profiles and off for public, I edited the question, is it needed to be on for public profile to block ip connections to websites? –  N_F_S Dec 27 '11 at 14:41
    
Server 2008 didn't actually implement those profiles completely. If the server is connected to multiple types of networks, say a Domain Network, and a second NIC connected to the public Internet. In that scenario both NICs will use the Rules for Domain Network; however if Enable/Disable still holds per NIC under each Profile. In your case any "Public" NICs will have the firewall disabled. This is not the case for 2008R2 (for anyone else reading this). –  Chris S Dec 27 '11 at 14:51

1 Answer 1

Public Profile is Active:
Firewall is OFF

You just answered your own question. The firewall for the Public Profile, which is the active one, is off. Any rule that you put in there won't matter until you enable it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.