Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am attempting to execute commands on remote machines in our network. I have successfully used psexec for this task, but I am running into an odd performance issue. psexec takes a long time to actually establish and run commands on remote machines (~30 seconds).

I originally thought this was a DNS issue, but the problem exists if I connect to the host using a domain name or an IP. I have added the remote host name to the etc/host file, but that has not helped. From a wireshark capture, I can see several attempts to connect to the remote machine on port 80 for some reason before my machine attempts to use more normal ports such as 445 or 135.

share|improve this question
    
Please detail what OS you are using for client and server and psexec version –  Sergei Dec 28 '11 at 12:25
    
Client: Windows 7 64-bit, Server: Windows 7 64-bit, psexec version: 1.98 –  adam35413 Dec 28 '11 at 13:34
    
does problem persists with different OS version?different version of psexec?If this issue started recently this is probably due to some change.Do you have access to clean installation of Windows 7 to test it? –  Sergei Dec 28 '11 at 13:37
    
I do not have access to a different version of windows to try this with. I do not think this is an issue with windows or psexec, I think it is a configuration issue. –  adam35413 Dec 28 '11 at 14:07
1  
It appears that when Windows firewall is enabled, connection attempts on port 80 are simply dropped rather than reset with a RST packet. When the firewall is off, Windows immediately sends a RST packet. This causes PsExec to cycle immediately to the next port option (445). –  adam35413 Dec 28 '11 at 14:34
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.