Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed Oracle 11g XE on a Windows 7 VirtualBox VM, using all the default options.

"Getting Started" fails

When I click on Getting Started I get taken to http://127.0.0.1:8080/apex/f?p=4950 which fails. After some browsing I came across a suggestion to confirm the HTTP port, but I can't get this far, because I can't connect.

connect system fails

If I select Run SQL command line I get taken to a SQL prompt. I enter connect system and get prompted for a password. I enter the password. I immediately get the following error:

ERROR:
ORA-01033: ORACLE initialization or shutdown in progress
Process ID: 0
Session ID: 0 Serial number: 0

Info: Start database

This happens whether or not I run Start database first. (Start database just opens a Windows command prompt window.)

Info: Windows services

My Oracle services start as follows:

Oracle XE services default startup

Starting the manual services doesn't resolve the problem. Enabling and starting the disabled service doesn't resolve the problem.

Is there something I haven't done? How can I resolve this connection error?

share|improve this question
    
Is Oracle Services working. Use net start command or services.msc to control. –  Atilla Ozgur Dec 28 '11 at 20:12
    
@AtillaOzgur thanks for the tip, I've added services info above, starting the unstarted services didn't resolve the issue however :( –  d3vid Dec 29 '11 at 8:21
    
try to login using sqlplus "/as sysdba" –  Atilla Ozgur Dec 29 '11 at 9:09
    
# Hi, I am also getting the same issue pop up(The installer is unable to instantiate the file C:\Users\SAMRAT\AppData\Local\Temp\{some value..}\KEY_XE.reg), so according to this blog I went to the path mentioned in the error pop up but could not find out the file “KEY_XE.reg” where I will set up the key data value.I am also installing in Windows7 64 bit.The DB installation file is “OracleXE112_Win32″.Please help me in resolving this issue.Thanks –  Sam Feb 14 '12 at 6:44

2 Answers 2

up vote 2 down vote accepted

For each and every unexpected behaviour/error see the installation logs at C:\oraclexe\app\oracle\product\11.2.0\server\config\log. It will tell what went wrongs during notifications.

In my case, it shows some thing related to windows events are full. I cleared all the events, de-install oracle and re-install. Everything is perfect.

share|improve this answer
    
I'm accepting this untested because I ended up creating another VM and the second time it worked; it's a helpful answer nonetheless, and at least a source of more info should someone else run into the same problem –  d3vid Nov 28 '12 at 7:09

The following seemed to work for me.

Open a browser and navigate to the below url, this should get you where you need to go:

http://[localhost]:8080/apex/f?p=4950

Actual port number (8080) may be different in your installation.

Taken from here: https://forums.oracle.com/forums/thread.jspa?messageID=9542052.

share|improve this answer
    
my original problem was that the URL failed; are you suggesting using the machine name and/or localhost instead of 127.0.0.1? –  d3vid Jan 29 '13 at 9:11

protected by Sven Dec 13 at 14:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.