Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This is a weird one for me. We have a total of 10 servers. 4 x Windows 2003 and 6 x Windows 2008. Yesterday all Windows XP machines stopped being able to access the shared printers and folders from one of the servers. "net view server01" returns system error 64 after several minutes on every single NT 5.x based machine I've tried it on (at least 15), a mix of Windows 2003 and XP machines.

From my Windows 7 laptop and from every single 2008 based server (NT 6.x) it works straight away.

A reboot of the server fixes the problem for about 5-10 minutes before all NT 5.x based clients stop working again.

I've swapped all the switches out, just in case it was a network issue, but it hasn't fixed it. I also removed Kaspersky from an XP machine, but that had no effect either.

The server in question in a Windows 2008 R1 Hyper-V VM running on Windows Server 2008 R2.

There is nothing in the event log of the server that seems to be relevant. Any ideas of where to look or what might be causing this?

share|improve this question
1  
We've worked out that this is an issue with SMB 1 (en.wikipedia.org/wiki/Server_Message_Block), as NT 6.x uses SMB 2. If we disable SMB 2 in the registry and reboot, then 2008 and Win7 clients also get the "System error 64 has occurred" when trying to view the shares via "net view". We're going to reinstall the file server role and see if that resolves it. Otherwise it's a call to MS support. I'll post what we find here, in case it helps someone elese. –  iamichi Dec 29 '11 at 13:37
1  
Just spent 4 hours on the phone with MS support. Main things we tried where merging the lanmanserver registry key with a working Windows 2008 server [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer] and rebooting. After that the error changed to "System error 53 has occurred", but still an SMB1 issue. After that we removed and rebound the virtual NIC in Hyper-V, which we thought fixed it, but 10 minutes later the issue came back. We'll take it up again tomorrow. –  iamichi Dec 30 '11 at 0:32

1 Answer 1

up vote 3 down vote accepted

It ended up being a problem with the virtual NIC on the host machine. The other Hyper-V VM didn't have a problem, so it was weird, but it turned out that the host machine which is running Windows 2008 R2, didn't have SP1 on it. We applied this hotfix http://support.microsoft.com/?kbid=974909, which I believe comes in 2008 R2 SP1 and the problem went away after a reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.