Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to install Xvfb on a RHEL 6.2 system using yum. However, all of the help that I've found says to type:

    yum install Xvfb

or...

    yum install xorg-x11-server-Xvfb

Which I'm sure would work if I had the correct repo configured, which I'm guessing I don't. Because I get the error:

    No package Xvfb available.

The only repos I have on this system are redhat.repo and rhel-source.repo. Which repo contains the Xvfb package?

Thanks!

share|improve this question

4 Answers 4

Umm, the package is called "xorg-x11-server-Xvfb" on CentOS5.

So you should be using the second option, "yum install xorg-x11-server-Xvfb". You can do "yum search xvfb" which gives you the proper name of the package, also.

share|improve this answer
    
Tried both of those, neither work. Search returns no matching packages, and "yum install xorg-x11-server-Xvfb" tells me "No package xorg-x11-server-Xvfb available". –  AWT Dec 28 '11 at 20:10
    
xorg-x11-server-Xvfb.i386 on my RHEL 5.5 machine.. Wonder if they axed it in 6.0 –  Tim Dec 28 '11 at 20:17
    
Weird. It's a standard RHEL package. Maybe run "yum clean" to clear out local data? This might be something you get to bug RH about. –  cjc Dec 28 '11 at 20:24
    
@Tim. On CentOS6.2, I see "xorg-x11-server-Xvfb.i686 0:1.10.4-6.el6_2.1" so it's derived from standard RHEL sources. It's also mentioned on this official RH doc: rhn.redhat.com/errata/RHBA-2011-1816.html so it should be available from RedHat. This sounds more like an issue with Torgis's yum configuration. –  cjc Dec 28 '11 at 20:26
    
Could very well be. I tried yum clean all, yum search all xvfb and get nothing. Which repos do you have added in /etc/yum.repos.d? I just looked at my redhat repo and it's blank. That's likely not good. –  AWT Dec 28 '11 at 20:33

It's available on the Client, Workstation, and Server Optional Channels inside RHN: (Note the URLs here will prompt for your redhat support account)

https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=xorg-x11-server-Xvfb&archIdList=&archLabelList=&search_subscribed_channels=yes

You'll need to configure the appropriate entitlement in order to use one of those channels with your system, of course.

You can search for packages at the following URL if you're not familiar with (or don't like) the Package Kit gui or the equivalent yum functionality:

https://rhn.redhat.com/rhn/channels/software/Search.do

cheers!

share|improve this answer
    
Silly question as a follow-up...once I have a support account, where do I put that information on my system so that these yum repositories will work? –  AWT Jan 3 '12 at 15:14
    
your link gives me anything... I believe that it doesn't work anymore.. –  caarlos0 Apr 9 '13 at 11:52
up vote 1 down vote accepted

Ok, I figured it out. The answer is to add the rhel-beta repository, thus bypassing the need for an RHN subscription:

[rhel-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

[rhel-beta-optional]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

Worked like a charm.

share|improve this answer
    
Downvoted for posting my solution. :) –  AWT Oct 24 '12 at 14:34
    
where are you supposed to put this configuration? –  slashdottir Sep 24 at 21:43

Thanks for explaining the solution...for some reason the ftp link for me was malformed and so I was getting errors such as...

ftp://ftp.redhat.com/pub/redhat/rhel/beta/6Server/x86_64/os/repodata/repomd.xml:[Errno 14] PYCURL ERROR 9 - "Server denied you to change to the given directory"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-beta. Please verify its path and try again

Notice the "6Server" part, that directory doesn't exist or something is wrong with what I was doing.

Anyway, I ended up replacing $releasever for now with "6" ftp://ftp.redhat.com/pub/redhat/rhel/beta/6/x86_64/os/repodata/repomd.xml

and from what I can tell the "sudo yum install xorg-x11-server-Xvfb" install it fine

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.