Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Is there a way way to allow permission to /flushdns in windows 7 or vista, to a certain user so even though he is not an administrator he can still do this and don't get this error?

The requested operation requires elevation.
share|improve this question

4 Answers 4

up vote 1 down vote accepted

In vista you can add the "network operator" role - that may include flushdns. Sadly, since 7 this seems to have gone AWOL :(

share|improve this answer
    
There is Network Configuration Operators group that I'm a member of, and it doesn't allow /flushdns –  user893730 Dec 29 '11 at 15:27
    
restart fixed the problem, it works –  user893730 Dec 29 '11 at 15:45
    
on 7? or just vista? –  Tom Newton Dec 29 '11 at 21:43
    
I only tested vista, thank you very much –  user893730 Jan 2 '12 at 7:52

The only way I can think of would be to configure a scheduled task, running with an administrator as Log On account with elevation, and when the user needs to flush the cache, they simply go to task scheduler, right-click the task and select "Run now".

Normal users won't be able to modify the task without verifying the administrator credentials (it will prompt for password when they try to apply changes), so they cannot abuse your account for anything else

share|improve this answer

I have heard (though not personally tested) that you can set these kinds of specific permissions using UAC (User Account Control) policies. Apparently they are actually much handier than we typically think (I often just disable it), but again I've not tried it...

share|improve this answer

My guess is that regmon from sysinternals might tell you what registry permissions are needed users to allow ipconfig /flushdns.

Offical Microsoft documentation mentions DNS related entries here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters

But several people have found in testing that the correct location for this entry should be:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.