Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Similar to How do I prevent one IP from creating a DNS entry on a multi-homed server? but I didn't get a clear answer there.

I have a host, call it EXCHANGE, with two IPs, 10.5.1.10 and 10.5.1.15. I want EXCHANGE` to resolve ONLY to 10.5.1.15. Everyday I have to go in and delete an automatically created DNS record on my Windows Server 2008 R2 DC. Everyday it updates this dynamically and re-creates the DNS entry I do not want. I do not know how to suppress this behavior and it would be great so that certificate errors will go away. I'm sure there is a way to do it but I cannot figure it out for the life of me.

share|improve this question
3  
It seems like the answer to the question you linked to would do the trick. Configure the NIC (assuming both ip addresses are assigned to the same NIC) to not register in DNS, then manually create an A record for the host name with the ip address that you do want in DNS. –  joeqwerty Dec 29 '11 at 0:46

2 Answers 2

up vote 2 down vote accepted

With Windows Server 2008 and Windows Server 2008 R2 there is now a new Method to selectively determine, which IP Address should be registered in DNS.

You can try this: netsh int ipv4 add address "LAN" skipassource=true

For more information, see: http://support.microsoft.com/kb/2386184 (included in R2 SP1) IP addresses are still registered on the DNS servers even if the IP addresses are not used for outgoing traffic on a computer that is running Windows 7 or Windows Server 2008 R2

Please note, that there is an additional Hotfix that you should be aware of: http://support.microsoft.com/kb/2554859 The "skipassource" flag of IP addresses is cleared after you use the GUI to change IP settings of a network adapter in Windows 7 or in Windows Server 2008 R2

Best Regards, J.

share|improve this answer

To configure the NIC as mentioned above, open up the NIC properties in control panel, select TCP/IPv4 then click properties, click the advanced button in the bottom right, then click the DNS tab, then uncheck the check box 2nd from bottom titled Register this connection's addresses in DNS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.