Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a basic Cisco 2960 switch, and I'm trying to figure out how to setup Vlans.

Basically I want to create a very simple Vlan layout, Vlan 1 for management, Vlan 2 for servers.

Despite my efforts I am unable to route both Vlans to the internet. I do not have access to switches or routers above my network. I've also installed the latest firmwared for the Cisco 2960 12.2 that allows static IP routing.

The issue here is I have let's say port gi51 as my uplink to my provider, gi1 - remote server, gi2-gi48 are my servers. When I set Vlan 2 to gi2-gi48 as untagged, they immediately loose internet, since gi51 is the uplink and set to untagged Vlan 1.

My question is, how can I route multiple untagged Vlans to the internet? Or am I going about this completely wrong? My basic goal is to segregate my servers broadcast domain in anyway possible. Thank you for any help offered.

share|improve this question

migrated from stackoverflow.com Dec 29 '11 at 8:46

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I think you are confusing your terms. Tagging and routing occur at different network layers.

You'll need to configure vlan interfaces on your switch, and you need to enable routing if you have not done that already.

Lets say for example that

  • vlan 1 is subnet 1.1.1.0/24
  • vlan 2 is subnet 2.2.2.0/24
  • the 'inside' interface of your internet router is 1.1.1.254

You need something like this on your router...

ip routing

interface vlan 1
ip address 1.1.1.1 255.255.255.0
no shut

interface vlan 2
ip address 2.2.2.1 255.255.255.0
no shut

ip route 0.0.0.0 0.0.0.0 1.1.1.254

Servers on vlan 2 would then need their IP addressing & gateway updating to reflect the vlan 2 address schema. Since you say vlan 1 already has internet connectivity, I would suppose that the interface & routing for vlan 1 is in place already.

As an aside I would recommend not using vlan 1 for anything as different vendors interpret traffic tagged into vlan 1 in different ways.

share|improve this answer
    
I hate to mention it, but there us no mention of a default route in this answer. And you should explain his options for the provider to route his traffic back to the subnets defined in your answer. In summary, this wont work as written. –  Mike Pennington Dec 30 '11 at 6:51
    
Mike - He states that vlan 1 already has internet connectivity. I assume that a default route is already in place. There is no mention of public addressing either so I also assume that there is an internet router or firewall ahead of the switch or that hides internally addressed traffic behind it. There isn't enough information provided to give a full configuration. –  paulos Dec 30 '11 at 10:38
    
you are responding to someone that demonstrates a basic lack of clue about IP routing, but you assume he already has a default? –  Mike Pennington Dec 30 '11 at 10:45
    
since the internet already works... yes? –  paulos Dec 30 '11 at 11:20
    
I'm confused, you put "ip routing" in the config, but you complain when someone suggests you actually put a route in it? –  Mike Pennington Dec 30 '11 at 11:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.