Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to migrate my site hosting from bluehost to AWS cloud based service.

I have the site up and running on AWS with an elastic IP configured, it loads fine when I specify the IP address in the browser.

I have gone into Route 53 on the AWS console and created a "hosted zone" for the domain. I then created a new record set of type "A" using the IP address as the value.

I have a domain name registered with bluehost. Ive logged into the bluehost account and updated the domain name servers to point to those specified in Route 53 in the AWS console.

When I hit the IP address directly the site loads, however it doesn't load when using the domain name (I get a google chrome oops error page saying page is not found)

I've tried using this site: http://dns.squish.net/ to debug but it seems to be giving me the correct results.

fizaclegems.com 300 IN  A   107.20.209.78

Where 107.20.209.78 matches the elastic IP configured in the AWS console. This is the result it gives for all 4 name servers.

Am I missing a step here? Does anyone know what else I should be doing or looking for?

share|improve this question
    
People might be able to offer more assistance if you provided the actual host name and IP address. –  Eric Hammond Dec 29 '11 at 19:02
    
Ok, updated the question –  Andrew Dec 29 '11 at 19:08
    
And it worked :-) –  Eric Hammond Dec 30 '11 at 1:50

1 Answer 1

fizaclegems.com appears to 301 redirect to www.fizaclegems.com, which has no A or CNAME record.

[] csternal@~: dig fizaclegems.com

; <<>> DiG 9.6-ESV-R4-P3 <<>> fizaclegems.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20507
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;fizaclegems.com.       IN  A

;; ANSWER SECTION:
fizaclegems.com.    300 IN  A   107.20.209.78

;; Query time: 142 msec
;; SERVER: 10.0.1.1#53(10.0.1.1)
;; WHEN: Thu Dec 29 14:39:45 2011
;; MSG SIZE  rcvd: 49

Versus:

[] csternal@~: dig www.fizaclegems.com

; <<>> DiG 9.6-ESV-R4-P3 <<>> www.fizaclegems.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 46305
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.fizaclegems.com.       IN  A

;; Query time: 13 msec
;; SERVER: 10.0.1.1#53(10.0.1.1)
;; WHEN: Thu Dec 29 14:40:16 2011
;; MSG SIZE  rcvd: 37
share|improve this answer
    
Great shout, Ive added an extra A record for www.fizaclegems.com and it seems to be loading correctly now. Thanks for the help! –  cowls Dec 29 '11 at 20:01
    
If this fixed your problem, please accept the answer by pressing the checkmark by it. –  ceejayoz Dec 29 '11 at 22:29
    
Annoyingly I've posted it under some strange account that I cant log back into... –  cowls Dec 29 '11 at 23:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.