Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run a simple powershell command on a remote PC such as

Get-WmiObject Win32_Process -computer Pc1

Some Pcs reply "Access denied", while other reply fine, but I can't get the difference.

Which rights are involved?

share|improve this question

Have you looked at this ServerFault question Which permissions/rights does a user need to have WMI access on remote machines?

share|improve this answer

Disable windows firewall first, to see if it's that simple; if so, you can narrow it down to individual ports.

share|improve this answer
I'd be very surprised if this was a firewall issue. The fact that some machines acquiesce, and others have the gaul to respond with a "Access denied" means the traffic is getting through to the target, and a response is getting back. – Izzy Jul 1 '09 at 16:37
Reason I mentioned it is that I once inherited a network where half the users had the firewall enabled, the other half didn't. I actually received access denied errors from the (WMI based) network monitoring software, which really wasn't what I expected, either. – Kara Marfia Jul 1 '09 at 17:14
Fair comment, I guess it pays it expect the unexpected! – Izzy Jul 3 '09 at 2:33

You need to be a local admin on the target PC, and you need to be using those credentials.

share|improve this answer

Non admins should be able to run PowerShell WMI queries if the WMI Control permissions are adjusted to allow access.

My research found the following... See KB 325353 and

On the target server: Computer Management | WMI Control | Security Tab Highlight Root\cimv2 node Click Security button For EVERYONE group, check Remote Enable box or add a group and grant Remote Enable and Enable Account.

I have not had a chance to test these settings yet. Pls verify on NON-PRODUCTION server first.

share|improve this answer
It is interesting, but unfortunately does not solve the problem. – sthiers Jul 15 '09 at 15:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.