Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Linux version is as follows:Red Hat Enterprise Linux Server release 5.5 (Tikanga) My rpm version is

when I am trying ti run uname -a ,the output i sas follows:

Linux 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

I have downloaded krb5-libs-1.8.4-3.fc14.x86_64.rpm from .

$ rpm -ivf krb5-libs-1.8.4-3.fc14.x86_64.rpm
warning: krb5-libs-1.8.4-3.fc14.x86_64.rpm: Header V4 DSA signature: NOKEY, key                                                                                                  ID 42d68235
error: Failed dependencies: is needed by krb5-libs-1.8.4-3.fc14.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by krb5-libs-1.8.4-3.fc14.x86_6                                                                                                 4
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by krb5-libs-1.8.4-3.fc14.x86_64

Please let me know which version of Keberos library should I download so that this error would be resolved or any other suggestion to resolve this issues.

share|improve this question

Ah, RPM Dependency management.. Or lack of.

You'd be better to configure yum to look at EPEL repositories, then use yum to install what you want, rather than using rpm.

Also, it looks like that version of krb5 requires a more recent version of glibc than you've got. This kinda upgrade tends to happen when you're looking at a version of a package that's a lot more recent than the current version for your RHEL build.

You're also trying to install packages from Fedora Core 14 onto a RHEL 5.5 system.
Are there not any vendor supported kerberos libraries? I mean, you're paying a shitload for support, you might as well use it.

Good luck getting it working without breaking the existing system.

But yeah.. You should be using yum, really.

share|improve this answer
So, I don't have a 5.5 box to pull this up on, but the current version for the 5 series is krb5-libs-1.6.1-62.el5. It is available in the base rhel-${arch}-(server|workstation)-5 channel. – Scott Pack Dec 30 '11 at 13:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.