Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to start a bridge connection and force it to use IGMPV3.

The following command will explain my issue better :

The below is the output of force_igmp_version before issuing brctl commands

/ # cat /proc/sys/net/ipv4/conf/br/force_igmp_version
3
/ # cat /proc/net/igmp
Idx     Device    : Count Querier       Group    Users Timer    Reporter
1       lo        :     1      V3
                        E0000001     1 0:00000000               0
3       eth0      :     1      V3
                        E0000001     1 0:00000000               0
4       eth1      :     1      V3
                        E0000001     1 0:00000000               0
5       eth2      :     1      V3
                        E0000001     1 0:00000000               0

Then I issue a set of brctl command to add a bridge and add my eth0 and eth1 interface to the bridge and do ifconfig on the bridge. But surprisingly bridge created is still using IGMPV2.

/ # cat /proc/net/igmp
Idx     Device    : Count Querier       Group    Users Timer    Reporter
1       lo        :     1      V3
                         E0000001     1 0:00000000               0
3       eth0      :     1      V3
                        E0000001     1 0:00000000               0
4       eth1      :     1      V3
                        E0000001     1 0:00000000               0
5       eth2      :     1      V3
                        E0000001     1 0:00000000               0
6       br        :     1      V2
                        E0000001     1 0:00000000               0

Is there anything I am missing to configure to make the bridge start with IGMPV3?

How can I force the bridge to use IGMPV3?

share|improve this question
add comment

1 Answer 1

I'm looking into this issue myself. So far i have found only that IGMPv3 is not supported in bridge, or at least not supported in all versions of linux kernel. I would try to dissable IGMP Snooping in bridge. I expect that then IGMPv3 packets will be sent.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.