Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The following is a line from the the mysql man page when accessed from my computer running ubuntu with the gnome gui

"Command-Line Options that Affect Option-File Handling".

This line gets rendered as this:

âCommand-Line Options that Affect Option-File Handlingâ

when I ssh into the ubuntu computer from my windows computer using putty.

Why are the quotes being rendered as â's? Is there any way I can get my ssh sessions to correctly render the man pages?

EDIT

Putty already has the "Terminal-type String" set to xterm, here is my .profile:

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

I don't think that the terminal type is being overridden

share|improve this question
    
I'm going to guess that the system you are ssh'ing from is a Windows machine, true? –  Peter Rowell Dec 30 '11 at 23:53
    
true indeed, im using putty to ssh –  user784637 Dec 31 '11 at 0:02

2 Answers 2

up vote 6 down vote accepted

Change your character set in PuTTY:

Window > Translation > Remote character set

  • The default character set is ISO-8859-1:1998 (Latin-1, West Europe)
  • Change it to UTF-8 for unicode support - which should render your characters correctly.

(I had this same problem with Amazon's Linux - the motd message had unicode characters, so it was a constant reminder and prompted me to hunt for a solution).

share|improve this answer
    
Pretty awesome, thanks so much I appreciate it! –  user784637 Dec 31 '11 at 21:40

Under either Connection or Connection->Data (depending on your version of PuTTY), you will see an entry "Terminal-type String". Try setting it to xterm.

Note that if your current user profile on the machine you are connecting to overrides your terminal type, you'll have to change it there. Look in your home directory for files that start with . and have profile in their name. (You can use ls -a ~/.*profile* to check.)

Note: Exercise extreme caution editing profile files. I recommend keeping one session logged in to revert any changes and confirming that you can log in a new session before logging out.

share|improve this answer
1  
+1 for keeping the safety session going while you get the kinks worked out. –  Peter Rowell Dec 31 '11 at 1:56
    
Thanks again David, please see my original post =), what line of code in .profile should tell me if the terminal type is being overridden? –  user784637 Dec 31 '11 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.